CVE-2026-73236
HighCVSS 7.5Exploitation Probability (EPSS)
Low risk27th percentile - higher than 27% of all known CVEs
Summary
An incorrect authorization vulnerability in Apache Syncope stems from flawed implementation of Realm hierarchy-based checks. Permission enforcement uses prefix matching, making it impossible to correctly distinguish between two sibling Realms whose names begin with the same string, leading to unauthorized access.
Risk Assessment
A user with privileges in one Realm may gain access to data in another Realm with a similar name, potentially leading to confidentiality and integrity violations.
Recommendation
Upgrade Apache Syncope to version 4.0.8 or 4.1.3. Until upgrading, avoid creating sibling Realms with names starting with the same string.
Other vulnerabilities in Apache Syncope
See all- CVE-2026-114364Unknown
Apache Syncope contains an incomplete fix for CVE-2026-77051 — an SQL injection vulnerability via unsanitized opEvent parameters. An administrator with adequate entitlements can execute arbitrary SQL through stacked queries.
- CVE-2026-113687Unknown
Apache Syncope has an improper isolation or compartmentalization vulnerability. An administrator with adequate entitlements for Implementations can create a malicious Groovy class that runs untrusted code on a separate thread, bypassing the Groovy security sandbox.
- CVE-2026-113511Unknown
Apache Syncope has an authorization bypass through a user-controlled key vulnerability. A delegated administrator can relocate a Realm subtree across administrative realm boundaries without permission for the destination.
- CVE-2026-110535Unknown
Apache Syncope has an improper privilege management vulnerability. AuthProfile self-updates allow non-admin users to configure impersonation for WA surrogate authentication.
- CVE-2026-109083Unknown
Apache Syncope has an improper isolation or compartmentalization vulnerability. An administrator with adequate entitlements can import arbitrary BPMN process definitions via the REST API and then start the process; when a BPMN process containing a JUEL expression is imported and started, the expression is executed directly on the server with no sandbox.
- CVE-2026-73370Critical
An incorrect authorization vulnerability in Apache Syncope affects the Reconciliation service (pull and push). Due to incomplete delegated administration security checks, calls by administrators lacking proper entitlements may be accepted, enabling unauthorized actions.
- CVE-2026-78330Critical
An incorrect privilege assignment vulnerability in Apache Syncope. When the configured JWKS settings for internal JWT authentication are disclosed (at least protocol and key), an attacker can obtain admin privileges after completing successful authentication and obtaining a valid low-privileges JWT.
- CVE-2026-77181Critical
Apache Syncope has an incorrect authorization vulnerability. An administrator with ClientApp's update entitlement is unable to perform the related operation, while ClientApp's create entitlement is checked both for create and update operations on ClientApp.
- CVE-2026-77051Critical
Apache Syncope has an SQL Injection vulnerability due to improper neutralization of special elements in SQL commands. An administrator with adequate entitlements can achieve execution of arbitrary SQL via stacked queries, leveraging unsanitized entityKey and opEvent parameters.
- CVE-2026-75030Critical
Apache Syncope has a missing authorization vulnerability. An administrator with task execution entitlements might be able to mass (de)provision group members, regardless of their group-related administration capabilities.
Original NVD description (English source)
Incorrect Authorization vulnerability in Apache Syncope. Delegated administration security checks are based on Realm hierarchy and enforced via prefix matches. Due to incorrect implementation, two sibling Realms whose names begin with the same string cannot be correctly distinguished, resulting in incorrect authorization. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

