CVE Catalog

CVE-2026-113687

Unknown
Published: Updated: Translated: NVD NIST

Summary

Apache Syncope has an improper isolation or compartmentalization vulnerability. An administrator with adequate entitlements for Implementations can create a malicious Groovy class that runs untrusted code on a separate thread, bypassing the Groovy security sandbox.

Risk Assessment

A user with administrative entitlements can execute arbitrary code in the server context, potentially leading to system compromise or access to other realms' data.

Recommendation

Upgrade Apache Syncope to version 4.0.9 or 4.1.4 and restrict Implementations management entitlements to trusted administrators only.

Other vulnerabilities in Apache Syncope

See all
Original NVD description (English source)

Improper isolation or compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class running untrusted code on a separate Thread, thus bypassing the Groovy security sandbox. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0-M0 through 4.1.3. Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS