CVE Catalog

CVE-2026-109083

Unknown
Published: Updated: Translated: NVD NIST

Summary

Apache Syncope has an improper isolation or compartmentalization vulnerability. An administrator with adequate entitlements can import arbitrary BPMN process definitions via the REST API and then start the process; when a BPMN process containing a JUEL expression is imported and started, the expression is executed directly on the server with no sandbox.

Risk Assessment

A user with administrative entitlements can execute arbitrary code on the server through a malicious BPMN definition, potentially leading to full system compromise.

Recommendation

Upgrade Apache Syncope to version 4.0.9 or 4.1.4, which reject BPMN definitions including expression attributes, and restrict BPMN process import entitlements.

Other vulnerabilities in Apache Syncope

See all
Original NVD description (English source)

Improper isolation or compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements can import arbitrary BPMN process definitions via the REST API and then start the process. When a BPMN process containing a JUEL expression is imported and started, the expression is executed directly on the server, with no sandbox. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0 through 4.1.3. Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue by rejecting BPMN definitions including expression attributes.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS