CVE-2026-42797
MediumCVSS 4.9Exploitation Probability (EPSS)
Low risk36th percentile - higher than 36% of all known CVEs
Summary
Apache Syncope versions 3.0 to 3.0.16, 4.0 to 4.0.5, and 4.1.0 have a sensitive information disclosure vulnerability via malicious JEXL expressions in Derived Schemas. An administrator with sufficient entitlements can access user-related security-sensitive information.
Risk Assessment
An attacker administrator can read confidential user data, compromising privacy and data security.
Recommendation
Update Apache Syncope to version 4.0.6 or 4.1.1, which restrict JEXL expression definitions.
Other vulnerabilities in Apache Syncope
See all- CVE-2026-114364Unknown
Apache Syncope contains an incomplete fix for CVE-2026-77051 — an SQL injection vulnerability via unsanitized opEvent parameters. An administrator with adequate entitlements can execute arbitrary SQL through stacked queries.
- CVE-2026-113687Unknown
Apache Syncope has an improper isolation or compartmentalization vulnerability. An administrator with adequate entitlements for Implementations can create a malicious Groovy class that runs untrusted code on a separate thread, bypassing the Groovy security sandbox.
- CVE-2026-113511Unknown
Apache Syncope has an authorization bypass through a user-controlled key vulnerability. A delegated administrator can relocate a Realm subtree across administrative realm boundaries without permission for the destination.
- CVE-2026-110535Unknown
Apache Syncope has an improper privilege management vulnerability. AuthProfile self-updates allow non-admin users to configure impersonation for WA surrogate authentication.
- CVE-2026-109083Unknown
Apache Syncope has an improper isolation or compartmentalization vulnerability. An administrator with adequate entitlements can import arbitrary BPMN process definitions via the REST API and then start the process; when a BPMN process containing a JUEL expression is imported and started, the expression is executed directly on the server with no sandbox.
- CVE-2026-73370Critical
An incorrect authorization vulnerability in Apache Syncope affects the Reconciliation service (pull and push). Due to incomplete delegated administration security checks, calls by administrators lacking proper entitlements may be accepted, enabling unauthorized actions.
- CVE-2026-78330Critical
An incorrect privilege assignment vulnerability in Apache Syncope. When the configured JWKS settings for internal JWT authentication are disclosed (at least protocol and key), an attacker can obtain admin privileges after completing successful authentication and obtaining a valid low-privileges JWT.
- CVE-2026-77181Critical
Apache Syncope has an incorrect authorization vulnerability. An administrator with ClientApp's update entitlement is unable to perform the related operation, while ClientApp's create entitlement is checked both for create and update operations on ClientApp.
- CVE-2026-77051Critical
Apache Syncope has an SQL Injection vulnerability due to improper neutralization of special elements in SQL commands. An administrator with adequate entitlements can achieve execution of arbitrary SQL via stacked queries, leveraging unsanitized entityKey and opEvent parameters.
- CVE-2026-75030Critical
Apache Syncope has a missing authorization vulnerability. An administrator with task execution entitlements might be able to mass (de)provision group members, regardless of their group-related administration capabilities.
Original NVD description (English source)
Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope. An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

