CVE-2026-25700
WysokieCVSS 7.2Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 39 - wyżej niż 39% wszystkich znanych CVE
Streszczenie
W podatności CVE-2026-25700 występuje niewłaściwe ograniczenie przypisania tokenów bezpieczeństwa w Apache Answer do wersji 2.0.0. Wydane wcześniej tokeny administracyjne nie były unieważniane po zawieszeniu, usunięciu lub dezaktywacji konta administratora, co umożliwiało dalszy dostęp do interfejsów API administracyjnych aż do wygaśnięcia tokenu.
Ocena ryzyka
Organizacja może być narażona na nieautoryzowany dostęp do interfejsów API administracyjnych, co może prowadzić do poważnych naruszeń bezpieczeństwa. Użytkownicy z nieaktualnymi tokenami mogą mieć dostęp do wrażliwych danych i funkcji systemu.
Rekomendacja
Zaleca się aktualizację do wersji 2.0.1, która naprawia tę podatność. Należy również rozważyć unieważnienie wszystkich aktywnych tokenów administracyjnych po zmianach w statusie konta administratora.
Inne podatności w Apache Answer
Zobacz wszystkie- CVE-2026-90910Krytyczne
W Apache Answer do wersji 2.0.2 występuje brak uwierzytelniania dla krytycznej funkcji. API reakcji nie egzekwowało kontroli widoczności treści, umożliwiając nieuprawnionym użytkownikom odczyt metadanych reakcji z ograniczonych treści oraz dodawanie i usuwanie własnych reakcji.
- CVE-2026-60053Krytyczne
Apache Answer do wersji 2.0.1 ma niewystarczające wygasanie sesji: administracyjne klucze API pozostają ważne po degradacji administratora lub po oznaczeniu konta jako nieaktywne, zawieszone lub usunięte, umożliwiając dalszy dostęp do czasu jawnego usunięcia kluczy.
- CVE-2026-86589Średnie
W Apache Answer do wersji 2.0.2 występuje nieprawidłowa implementacja algorytmu uwierzytelniania. Błąd w integracji logowania User Center może powodować, że nowo utworzona sesja użytkownika zewnętrznego pomija swoją tożsamość zewnętrzną, pozwalając kolejnym żądaniom ominąć kontrole zawieszenia lub usunięcia konta do czasu wygaśnięcia lub unieważnienia sesji.
- CVE-2026-79633Niskie ryzyko· EPSS 10%
W Apache Answer do wersji 2.0.2 występuje brak kontroli autoryzacji. Uwierzytelnieni użytkownicy mogli wykonywać działania na niepublicznych treściach, do których nie mieli uprawnień dostępu.
- CVE-2026-79624Niskie ryzyko· EPSS 10%
W Apache Answer do wersji 2.0.2 występuje niewystarczające wygasanie sesji. Nieodpowiednie unieważnianie sesji pozwalało odwołanym użytkownikom nadal uzyskiwać dostęp do znanych prywatnych przesłanych plików przy użyciu nieaktualnego tokenu wizyty.
- CVE-2026-79620Niskie ryzyko· EPSS 10%
W Apache Answer do wersji 2.0.2 występuje ujawnienie poufnych informacji przez zapytania do danych. Nieprawidłowa kontrola autoryzacji w wyszukiwaniu podobnych pytań pozwalała uwierzytelnionym użytkownikom przeglądać metadane niepublicznych pytań.
- CVE-2026-79613Niskie ryzyko· EPSS 6%
W Apache Answer do wersji 2.0.2 nieuwierzytelnieni atakujący mogą uzyskać dostęp do komentarzy powiązanych z treściami niepublicznymi poprzez publiczne profile użytkowników. Luka wynika z niewystarczającej kontroli widoczności komentarzy.
- CVE-2026-76994Niskie ryzyko· EPSS 7%
W Apache Answer do wersji 2.0.2 nieuwierzytelnieni atakujący mogą uzyskać metadane powiązane z ukrytymi pytaniami poprzez publiczne profile odpowiedzi. Luka polega na ujawnieniu informacji wrażliwych nieuprawnionym podmiotom.
- CVE-2026-71563Średnie
W Apache Answer do wersji 2.0.2 występuje brak autoryzacji w narzędziu MCP do pobierania odpowiedzi. Posiadacze globalnego klucza API mogą uzyskać dostęp do treści odpowiedzi powiązanych z pytaniami ukrytymi, usuniętymi lub oczekującymi na przegląd.
- CVE-2026-68482Średnie
W Apache Answer do wersji 2.0.2 nieuwierzytelniony lub nieuprawniony użytkownik może pobrać listę zaproszonych użytkowników powiązaną z niepublicznym pytaniem. Przyczyną jest brak kontroli autoryzacji widoczności.
Oryginalny opis (angielski, źródło NVD)
Improper Restriction of Security Token Assignment vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.0. Previously issued administrative tokens were not invalidated after an administrator account was suspended, deleted, or deactivated, allowing continued access to administrative APIs until the token expired. Users are recommended to upgrade to version 2.0.1, which fixes the issue.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

