CVE-2026-25700
HighCVSS 7.2Exploitation Probability (EPSS)
Low risk39th percentile - higher than 39% of all known CVEs
Summary
CVE-2026-25700 describes an improper restriction of security token assignment vulnerability in Apache Answer up to version 2.0.0. Previously issued administrative tokens were not invalidated after an administrator account was suspended, deleted, or deactivated, allowing continued access to administrative APIs until the token expired.
Risk Assessment
The organization may be exposed to unauthorized access to administrative APIs, potentially leading to serious security breaches. Users with stale tokens may have access to sensitive data and system functions.
Recommendation
It is recommended to upgrade to version 2.0.1, which fixes the issue. Additionally, consider invalidating all active administrative tokens after changes to the administrator account status.
Other vulnerabilities in Apache Answer
See all- CVE-2026-90910Critical
Apache Answer through 2.0.2 has a missing authentication for critical function vulnerability. The reaction API did not enforce content visibility controls, allowing unauthorized users to read reaction metadata from restricted content or add and remove their own reactions.
- CVE-2026-60053Critical
Apache Answer through version 2.0.1 has insufficient session expiration: administrative API keys remain usable after the owning administrator is demoted or the account is marked inactive, suspended, or deleted, allowing continued access until the keys are explicitly removed.
- CVE-2026-86589Medium
Apache Answer through 2.0.2 has an incorrect implementation of authentication algorithm vulnerability. A flaw in the User Center login integration can cause a newly created external user session to omit its external identity, allowing subsequent requests to bypass central account suspension or deletion checks until the session expires or is revoked.
- CVE-2026-79633Low risk· EPSS 10%
Apache Answer through 2.0.2 has a missing authorization checks vulnerability. Authenticated users could perform actions on non-public content they were not permitted to access.
- CVE-2026-79624Low risk· EPSS 10%
Apache Answer through 2.0.2 has an insufficient session expiration vulnerability. Insufficient session invalidation allowed revoked users to continue accessing known private uploaded files with a stale visit token.
- CVE-2026-79620Low risk· EPSS 10%
Apache Answer through 2.0.2 has an exposure of sensitive information through data queries vulnerability. An improper authorization check in the similar-question search allowed authenticated users to view metadata of non-public questions.
- CVE-2026-79613Low risk· EPSS 6%
In Apache Answer through 2.0.2, unauthenticated attackers could access comments associated with non-public content through public user profiles. The flaw stems from insufficient visibility checks on comments.
- CVE-2026-76994Low risk· EPSS 7%
In Apache Answer through 2.0.2, unauthenticated attackers could obtain metadata associated with hidden questions through public answer profiles. This is an exposure of sensitive information to unauthorized actors.
- CVE-2026-71563Medium
In Apache Answer through 2.0.2, an authorization flaw in the MCP answer retrieval tool allows holders of a global API key to access answer content associated with hidden, deleted, or pending-review questions.
- CVE-2026-68482Medium
In Apache Answer through 2.0.2, an unauthenticated or unauthorized user can retrieve the invited-user list associated with a non-public question due to missing visibility authorization checks.
Original NVD description (English source)
Improper Restriction of Security Token Assignment vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.0. Previously issued administrative tokens were not invalidated after an administrator account was suspended, deleted, or deactivated, allowing continued access to administrative APIs until the token expired. Users are recommended to upgrade to version 2.0.1, which fixes the issue.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

