Katalog CVE

CVE-2025-59944

WysokieCVSS 8.0
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.41%

Percentyl 34 - wyżej niż 34% wszystkich znanych CVE

Streszczenie

Cursor IDE w wersjach 1.6.23 i starszych stosuje sprawdzanie wielkości liter przy ochronie plików wrażliwych (np. */.cursor/mcp.json), co pozwala atakującemu zmodyfikować ich zawartość przez prompt injection. Na systemach plików nierozróżniających wielkości liter może to prowadzić do pełnego zdalnego wykonania kodu.

Ocena ryzyka

Atakujący może uzyskać wykonanie kodu na stacji roboczej dewelopera, np. przez spreparowaną treść w repozytorium lub odpowiedzi modelu.

Rekomendacja

Zaktualizuj Cursor do wersji 1.7 lub nowszej.

Inne podatności w Cursor

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Cursor is a code editor built for programming with AI. Versions 1.6.23 and below contain case-sensitive checks in the way Cursor IDE protects its sensitive files (e.g., */.cursor/mcp.json), which allows attackers to modify the content of these files through prompt injection and achieve remote code execution. A prompt injection can lead to full RCE through modifying sensitive files on case-insensitive fileystems. This issue is fixed in version 1.7.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS