Katalog CVE

CVE-2025-61591

WysokieCVSS 8.8
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Podwyższone ryzyko
1.16%

Percentyl 67 - wyżej niż 67% wszystkich znanych CVE

Streszczenie

Cursor w wersji 1.7 i wcześniejszych, gdy MCP używa uwierzytelniania OAuth z niezaufanym serwerem MCP, pozwala atakującemu podszyć się pod złośliwy serwer MCP i zwrócić spreparowane, złośliwie wstrzyknięte polecenia podczas interakcji, prowadząc do wstrzyknięcia poleceń i potencjalnego zdalnego wykonania kodu. Może to doprowadzić do wykonania dowolnego kodu na hoście przez agenta z pełnymi uprawnieniami użytkownika. Brak oficjalnej wersji poprawki, ale istnieje łatka 2025.09.17-25b418f.

Ocena ryzyka

Atakujący może wykonać dowolne polecenia z uprawnieniami użytkownika, przejmując kontrolę nad systemem, kradnąc dane lub instalując złośliwe oprogramowanie.

Rekomendacja

Zastosuj łatkę 2025.09.17-25b418f lub nowszą. Unikaj łączenia się z niezaufanymi serwerami MCP przez OAuth.

Inne podatności w Cursor

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Cursor is a code editor built for programming with AI. In versions 1.7 and below, when MCP uses OAuth authentication with an untrusted MCP server, an attacker can impersonate a malicious MCP server and return crafted, maliciously injected commands during the interaction process, leading to command injection and potential remote code execution. If chained with an untrusted MCP service via OAuth, this command injection vulnerability could allow arbitrary code execution on the host by the agent. This can then be used to directly compromise the system by executing malicious commands with full user privileges. This issue does not currently have a fixed release version, but there is a patch, 2025.09.17-25b418f.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS