CVE Catalog

CVE-2025-59944

HighCVSS 8.0
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.41%

34th percentile - higher than 34% of all known CVEs

Summary

Cursor IDE versions 1.6.23 and below use case-sensitive checks when protecting sensitive files (e.g., */.cursor/mcp.json), allowing attackers to modify their content via prompt injection. On case-insensitive filesystems this can lead to full remote code execution.

Risk Assessment

An attacker may achieve code execution on a developer workstation, for example through crafted repository content or model responses.

Recommendation

Upgrade Cursor to version 1.7 or later.

Other vulnerabilities in Cursor

See all
Original NVD description (English source)

Cursor is a code editor built for programming with AI. Versions 1.6.23 and below contain case-sensitive checks in the way Cursor IDE protects its sensitive files (e.g., */.cursor/mcp.json), which allows attackers to modify the content of these files through prompt injection and achieve remote code execution. A prompt injection can lead to full RCE through modifying sensitive files on case-insensitive fileystems. This issue is fixed in version 1.7.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS