CVE Catalog

CVE-2026-110181

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.27%

19th percentile - higher than 19% of all known CVEs

Summary

PostgreSQL Anonymizer before 3.3.0 mishandles anonymization functions defined using SQL-standard function bodies. PostgreSQL analyzes such functions at declaration time while Anonymizer only checks them at execution time, which can be exploited by any user with the TEMPORARY privilege.

Risk Assessment

A user with the TEMPORARY privilege may bypass anonymization mechanisms and access unmasked data, violating data protection policy.

Recommendation

Upgrade PostgreSQL Anonymizer to version 3.3.0 or later and restrict the TEMPORARY privilege to essential users.

Other vulnerabilities in PostgreSQL Anonymizer

See all
Original NVD description (English source)

PostgreSQL Anonymizer contains a vulnerability related to anonymization functions defined using SQL-standard function bodies. PostgreSQL analyses such functions at declaration time, while Anonymizer only attempts to check them at execution time. This problem can be exploited by any user with the TEMPORARY privilege. The issue is fixed in PostgreSQL Anonymizer 3.3.0 and later versions.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS