Katalog CVE

CVE-2026-110181

ŚrednieCVSS 6.5
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.27%

Percentyl 19 - wyżej niż 19% wszystkich znanych CVE

Streszczenie

PostgreSQL Anonymizer przed wersją 3.3.0 nieprawidłowo obsługuje funkcje anonimizujące zdefiniowane za pomocą ciał funkcji w standardzie SQL. PostgreSQL analizuje takie funkcje w momencie deklaracji, podczas gdy Anonymizer sprawdza je dopiero przy wykonaniu, co może wykorzystać każdy użytkownik z uprawnieniem TEMPORARY.

Ocena ryzyka

Użytkownik z uprawnieniem TEMPORARY może obejść mechanizmy anonimizacji i uzyskać dostęp do niezamaskowanych danych, naruszając politykę ochrony danych.

Rekomendacja

Zaktualizuj PostgreSQL Anonymizer do wersji 3.3.0 lub nowszej oraz ogranicz przyznawanie uprawnienia TEMPORARY niezbędnym użytkownikom.

Inne podatności w PostgreSQL Anonymizer

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

PostgreSQL Anonymizer contains a vulnerability related to anonymization functions defined using SQL-standard function bodies. PostgreSQL analyses such functions at declaration time, while Anonymizer only attempts to check them at execution time. This problem can be exploited by any user with the TEMPORARY privilege. The issue is fixed in PostgreSQL Anonymizer 3.3.0 and later versions.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS