CVE-2026-64944
Niskie ryzyko· EPSS 11%Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 11 - wyżej niż 11% wszystkich znanych CVE
Streszczenie
W Apache Answer do wersji 2.0.2 importer zapisuje importowane treści pytań jako surowy HTML bez przejścia przez normalną sanityzację Markdown-do-HTML. Atakujący może osadzić złośliwy HTML w importowanym źródle danych, który jest utrwalany i renderowany wszystkim przeglądającym jako stored XSS.
Ocena ryzyka
Złośliwy skrypt może wykonać się w przeglądarce użytkowników, w tym uprzywilejowanych, umożliwiając kradzież sesji lub wykonanie działań w ich imieniu.
Rekomendacja
Zaktualizuj Apache Answer do wersji 2.0.3, która naprawia tę podatność.
Inne podatności w Apache Answer
Zobacz wszystkie- CVE-2026-90910Krytyczne
W Apache Answer do wersji 2.0.2 występuje brak uwierzytelniania dla krytycznej funkcji. API reakcji nie egzekwowało kontroli widoczności treści, umożliwiając nieuprawnionym użytkownikom odczyt metadanych reakcji z ograniczonych treści oraz dodawanie i usuwanie własnych reakcji.
- CVE-2026-60053Krytyczne
Apache Answer do wersji 2.0.1 ma niewystarczające wygasanie sesji: administracyjne klucze API pozostają ważne po degradacji administratora lub po oznaczeniu konta jako nieaktywne, zawieszone lub usunięte, umożliwiając dalszy dostęp do czasu jawnego usunięcia kluczy.
- CVE-2026-86589Średnie
W Apache Answer do wersji 2.0.2 występuje nieprawidłowa implementacja algorytmu uwierzytelniania. Błąd w integracji logowania User Center może powodować, że nowo utworzona sesja użytkownika zewnętrznego pomija swoją tożsamość zewnętrzną, pozwalając kolejnym żądaniom ominąć kontrole zawieszenia lub usunięcia konta do czasu wygaśnięcia lub unieważnienia sesji.
- CVE-2026-79633Niskie ryzyko· EPSS 10%
W Apache Answer do wersji 2.0.2 występuje brak kontroli autoryzacji. Uwierzytelnieni użytkownicy mogli wykonywać działania na niepublicznych treściach, do których nie mieli uprawnień dostępu.
- CVE-2026-79624Niskie ryzyko· EPSS 10%
W Apache Answer do wersji 2.0.2 występuje niewystarczające wygasanie sesji. Nieodpowiednie unieważnianie sesji pozwalało odwołanym użytkownikom nadal uzyskiwać dostęp do znanych prywatnych przesłanych plików przy użyciu nieaktualnego tokenu wizyty.
- CVE-2026-79620Niskie ryzyko· EPSS 10%
W Apache Answer do wersji 2.0.2 występuje ujawnienie poufnych informacji przez zapytania do danych. Nieprawidłowa kontrola autoryzacji w wyszukiwaniu podobnych pytań pozwalała uwierzytelnionym użytkownikom przeglądać metadane niepublicznych pytań.
- CVE-2026-79613Niskie ryzyko· EPSS 6%
W Apache Answer do wersji 2.0.2 nieuwierzytelnieni atakujący mogą uzyskać dostęp do komentarzy powiązanych z treściami niepublicznymi poprzez publiczne profile użytkowników. Luka wynika z niewystarczającej kontroli widoczności komentarzy.
- CVE-2026-76994Niskie ryzyko· EPSS 7%
W Apache Answer do wersji 2.0.2 nieuwierzytelnieni atakujący mogą uzyskać metadane powiązane z ukrytymi pytaniami poprzez publiczne profile odpowiedzi. Luka polega na ujawnieniu informacji wrażliwych nieuprawnionym podmiotom.
- CVE-2026-71563Średnie
W Apache Answer do wersji 2.0.2 występuje brak autoryzacji w narzędziu MCP do pobierania odpowiedzi. Posiadacze globalnego klucza API mogą uzyskać dostęp do treści odpowiedzi powiązanych z pytaniami ukrytymi, usuniętymi lub oczekującymi na przegląd.
- CVE-2026-68482Średnie
W Apache Answer do wersji 2.0.2 nieuwierzytelniony lub nieuprawniony użytkownik może pobrać listę zaproszonych użytkowników powiązaną z niepublicznym pytaniem. Przyczyną jest brak kontroli autoryzacji widoczności.
Oryginalny opis (angielski, źródło NVD)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.2. The importer stores imported question bodies as raw HTML without passing them through the normal Markdown-to-HTML sanitization path, so attacker-controlled HTML embedded in an imported data source is persisted and rendered to all viewers (including privileged users) as stored XSS. Users are recommended to upgrade to version 2.0.3, which fixes the issue.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

