CVE-2026-58187
NiskieCVSS 3.7Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 46 - wyżej niż 46% wszystkich znanych CVE
Streszczenie
Wtyczka multipleksera Apache Traffic Server przepełnia bufor dekodowania fragmentów na wejściu nadrzędnym, co umożliwia atak denial of service. Problem dotyczy wersji od 8.0.0 do 8.1.11, od 9.0.0 do 9.2.14 oraz od 10.0.0 do 10.1.3. Zalecane jest uaktualnienie do wersji 9.2.15 lub 10.1.4, które naprawiają problem.
Ocena ryzyka
Podatność może zostać wykorzystana do przerwania działania serwera proxy, co prowadzi do niedostępności usług dla użytkowników.
Rekomendacja
Należy jak najszybciej zaktualizować Apache Traffic Server do wersji 9.2.15 lub 10.1.4, aby uniknąć ataków DoS.
Inne podatności w Apache Traffic Server
Zobacz wszystkie- CVE-2017-5659Wysokie
Apache Traffic Server w wersjach przed 6.2.1 generuje zrzut pamięci, gdy występuje niezgodność między długością treści a kodowaniem chunked.
- CVE-2016-5396Wysokie
Apache Traffic Server w wersjach od 6.0.0 do 6.2.0 jest podatny na atak typu HPACK Bomb.
- CVE-2014-3525Wysokie
Nieokreślona podatność w Apache Traffic Server w wersjach 3.x do 3.2.5, 4.x przed 4.2.1.1 oraz 5.x przed 5.0.1. Podatność ta może być związana z kontrolami stanu, jednak jej wpływ i wektory ataku są nieznane.
- CVE-2026-111815Krytyczne
Apache Traffic Server może wznowić sesję TLS między wirtualnymi hostami SNI bez ponownej weryfikacji certyfikatu klienta wymaganego przez politykę verify_client STRICT wznowionego hosta. Podatność dotyczy wersji od 8.0.0 do 8.1.11, od 9.0.0 do 9.2.15, od 10.0.0 do 10.1.4 oraz 10.2.0.
- CVE-2026-111814Krytyczne
Domyślna polityka współdzielenia sesji wychodzących Apache Traffic Server może ponownie użyć sesji TLS uwierzytelnionej jednym certyfikatem klienta dla transakcji skonfigurowanej do przedstawienia innego certyfikatu. Podatność dotyczy wersji od 9.0.0 do 9.2.15, od 10.0.0 do 10.1.4 oraz 10.2.0.
- CVE-2026-111812Krytyczne
Wtyczka origin_server_auth w Apache Traffic Server pozwala klientowi wymusić podpisywanie nagłówków żądań AWS wybranych przez atakującego, przy użyciu poświadczeń samego proxy. Podatność dotyczy wersji 8.0.0–8.1.11, 9.0.0–9.2.15, 10.0.0–10.1.4 oraz 10.2.0.
- CVE-2026-111811Krytyczne
Eksperymentalna wtyczka tsmemcache w Apache Traffic Server pozwala nieuwierzytelnionemu użytkownikowi sieci na odczyt, zapis i usuwanie współdzielonego cache proxy. Podatność dotyczy wersji 8.0.0–8.1.11, 9.0.0–9.2.15, 10.0.0–10.1.4 oraz 10.2.0.
- CVE-2026-111809Krytyczne
Apache Traffic Server pozwala na przemyt żądań (request smuggling) poprzez żądania HEAD zawierające nagłówki Content-Length lub Transfer-Encoding. Podatność dotyczy wersji od 8.0.0 do 8.1.11, od 9.0.0 do 9.2.15, od 10.0.0 do 10.1.4 oraz 10.2.0.
- CVE-2026-111816Krytyczne
Apache Traffic Server przetwarza nieprawidłowe odpowiedzi 302, które powinny zostać odrzucone jako błąd parsowania, z powodu obejścia ścieżki odrzucania przez wyjątek Transfer-Encoding: chunked. Odpowiedź, którą dwa węzły mogą odczytać różnie, jest przechowywana i serwowana, co umożliwia zatruwanie pamięci podręcznej i desynchronizację ramkowania odpowiedzi.
- CVE-2026-111813Krytyczne
Eksperymentalna wtyczka magick w Apache Traffic Server pozwala nieuwierzytelnionemu klientowi kontrolować argumenty polecenia ImageMagick convert w konfiguracji domyślnej (niepodpisanej). Podatność dotyczy wersji 8.0.1–8.1.11, 9.0.0–9.2.15, 10.0.0–10.1.4 oraz 10.2.0.
Oryginalny opis (angielski, źródło NVD)
The Apache Traffic Server multiplexer plugin overruns its chunk-decode buffer on upstream input, enabling denial of service. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

