Katalog CVE

CVE-2026-44581

ŚrednieCVSS 4.7
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.22%

Percentyl 13 - wyżej niż 13% wszystkich znanych CVE

Streszczenie

Next.js to framework React do budowy aplikacji full-stack. W wersjach od 13.4.0 do przed 15.5.16 oraz 16.2.5 aplikacje App Router korzystające z nonce CSP mogą być podatne na przechowywany cross-site scripting przy wdrożeniu za współdzielonymi cache'ami. Zniekształcone wartości nonce pochodzące z nagłówków żądań mogły być odzwierciedlane w renderowanym HTML w niebezpieczny sposób, co pozwalało zatruć odpowiedzi w cache i spowodować wykonanie skryptu u późniejszych odwiedzających.

Ocena ryzyka

Atakujący może zatruć współdzielony cache i doprowadzić do wykonania złośliwego skryptu w przeglądarkach innych użytkowników. Może to prowadzić do kradzieży sesji lub działań w imieniu ofiar.

Rekomendacja

Zaktualizuj Next.js do wersji 15.5.16 lub 16.2.5. Do czasu aktualizacji rozważ wyłączenie współdzielonego cache'owania dla aplikacji korzystających z nonce CSP.

Inne podatności w Next.js

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Next.js is a React framework for building full-stack web applications. From 13.4.0 to before 15.5.16 and 16.2.5, App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. In affected versions, malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors. This vulnerability is fixed in 15.5.16 and 16.2.5.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS