CVE Catalog

CVE-2026-44581

MediumCVSS 4.7
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.22%

13th percentile - higher than 13% of all known CVEs

Summary

Next.js is a React framework for building full-stack web applications. From 13.4.0 to before 15.5.16 and 16.2.5, App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. Malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors.

Risk Assessment

An attacker could poison a shared cache and cause malicious script execution in other users' browsers. This may lead to session theft or actions performed on behalf of victims.

Recommendation

Update Next.js to 15.5.16 or 16.2.5. Until then, consider disabling shared caching for applications using CSP nonces.

Other vulnerabilities in Next.js

See all
Original NVD description (English source)

Next.js is a React framework for building full-stack web applications. From 13.4.0 to before 15.5.16 and 16.2.5, App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. In affected versions, malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors. This vulnerability is fixed in 15.5.16 and 16.2.5.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS