Katalog CVE

CVE-2026-41887

ŚrednieCVSS 4.9
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.47%

Percentyl 41 - wyżej niż 41% wszystkich znanych CVE

Streszczenie

W Flarum przed wersjami 1.8.16 i 2.0.0-rc.1 poprawka dla CVE-2023-27577 ograniczyła funkcje LESS @import i data-uri() tylko w ustawieniu custom_less, ale nie w innych ustawieniach rejestrowanych jako zmienne konfiguracyjne LESS (np. theme_primary_color, theme_secondary_color oraz klucze rejestrowane przez Extend\Settings::registerLessConfigVar()). Wartości te są wstawiane dosłownie do źródła LESS w czasie kompilacji, umożliwiając uwierzytelnionemu administratorowi wstrzyknięcie dowolnej dyrektywy @import do forum.css. Ponieważ parser LESS honoruje @import (inline) '<path>', atakujący może odczytać dowolne pliki dostępne dla procesu PHP (LFI) lub wywołać wychodzące żądania HTTP(S) (SSRF). Podatność naprawiono w wersjach 1.8.16 i 2.0.0-rc.1.

Ocena ryzyka

Może to prowadzić do ujawnienia poufnych plików lub wykorzystania serwera do ataków SSRF na zasoby wewnętrzne. Ryzyko dotyczy organizacji używających Flarum z administratorami mogącymi modyfikować ustawienia motywu.

Rekomendacja

Zaktualizuj Flarum do wersji 1.8.16 lub 2.0.0-rc.1 (lub nowszej). Ogranicz uprawnienia administracyjne do niezbędnego minimum.

Inne podatności w Flarum

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Flarum is open-source forum software. Prior to versions 1.8.16 and 2.0.0-rc.1, Flarum's patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the custom_less setting, but the same restriction was never applied to other settings registered as LESS config variables (for example theme_primary_color and theme_secondary_color, as well as any key registered via Extend\Settings::registerLessConfigVar()). Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '<path>', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery). This issue has been patched in versions 1.8.16 and 2.0.0-rc.1.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS