CVE Catalog

CVE-2026-41887

MediumCVSS 4.9
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.47%

41th percentile - higher than 41% of all known CVEs

Summary

In Flarum prior to versions 1.8.16 and 2.0.0-rc.1, the patch for CVE-2023-27577 restricted LESS @import and data-uri() features only in the custom_less setting, but not in other settings registered as LESS config variables (e.g., theme_primary_color, theme_secondary_color, and keys registered via Extend\Settings::registerLessConfigVar()). These values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to inject an arbitrary @import directive into the compiled forum.css. Since the LESS parser honors @import (inline) '<path>', an attacker can read arbitrary files reachable by the PHP process (LFI) or trigger outbound HTTP(S) requests (SSRF). The issue is patched in versions 1.8.16 and 2.0.0-rc.1.

Risk Assessment

This can lead to disclosure of sensitive files or use of the server for SSRF attacks against internal resources. The risk affects organizations using Flarum with administrators able to modify theme settings.

Recommendation

Upgrade Flarum to version 1.8.16 or 2.0.0-rc.1 (or later). Restrict administrative permissions to the minimum necessary.

Other vulnerabilities in Flarum

See all
Original NVD description (English source)

Flarum is open-source forum software. Prior to versions 1.8.16 and 2.0.0-rc.1, Flarum's patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the custom_less setting, but the same restriction was never applied to other settings registered as LESS config variables (for example theme_primary_color and theme_secondary_color, as well as any key registered via Extend\Settings::registerLessConfigVar()). Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '<path>', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery). This issue has been patched in versions 1.8.16 and 2.0.0-rc.1.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS