CVE-2026-41043
ŚrednieCVSS 6.5Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 46 - wyżej niż 46% wszystkich znanych CVE
Streszczenie
Apache ActiveMQ i ActiveMQ Web zawierają podatność Basic XSS polegającą na niewłaściwej neutralizacji tagów HTML w konsoli webowej. Uwierzytelniony atakujący może wyświetlić złośliwą treść podczas przeglądania kolejek, nadpisując typ zawartości na HTML i wstrzykując HTML w pole selektora JMS. Problem dotyczy wersji przed 5.19.6 oraz 6.0.0–6.2.5.
Ocena ryzyka
Uwierzytelniony atakujący może wykonać skrypt w przeglądarce innych użytkowników konsoli, co może prowadzić do kradzieży sesji lub działań w ich imieniu. Wymaga konta w ActiveMQ, ale może eskalować uprawnienia.
Rekomendacja
Zaktualizuj Apache ActiveMQ i ActiveMQ Web do wersji 6.2.5 lub 5.19.6 (lub nowszej). Ogranicz dostęp do konsoli webowej do zaufanych sieci.
Inne podatności w Apache ActiveMQ
Zobacz wszystkie- CVE-2014-3576Wysokie
Funkcja processControlCommand w broker/TransportConnection.java w Apache ActiveMQ przed wersją 5.11.0 umożliwia zdalnym atakującym spowodowanie odmowy usługi (shutdown) za pomocą polecenia shutdown.
- CVE-2026-40466Wysokie
Podatność w Apache ActiveMQ umożliwia uwierzytelnionemu atakującemu ominięcie poprawki z CVE-2026-34197 poprzez dodanie konektora z wykorzystaniem transportu HTTP Discovery. Atakujący może użyć złośliwego punktu końcowego HTTP, który zwraca transport VM, co pozwala na załadowanie zdalnego kontekstu aplikacji Spring XML i wykonanie dowolnego kodu na JVM brokera.
- CVE-2026-34197WysokieAktywnie exploitowane
Podatność w Apache ActiveMQ umożliwia uwierzytelnionemu atakującemu zdalne wykonanie kodu na serwerze poprzez endpoint Jolokia JMX-HTTP. Atak polega na wywołaniu operacji dodania łącznika sieciowego z fałszywym URI, który ładuje zdalny kontekst Spring XML, co prowadzi do wykonania dowolnego kodu w JVM brokera.
- CVE-2015-5254Krytyczne
Apache ActiveMQ w wersjach 5.x przed 5.13.0 nie ogranicza klas, które mogą być serializowane w brokerze, co pozwala zdalnym atakującym na wykonanie dowolnego kodu za pomocą spreparowanego obiektu Java Message Service (JMS) ObjectMessage.
- CVE-2026-74761Wysokie
Nieprawidłowa walidacja danych wejściowych w komponencie TopicRegion w Apache ActiveMQ, Apache ActiveMQ Broker i Apache ActiveMQ All na wszystkich platformach. Uwierzytelniony klient może sfałszować clientId podczas usuwania trwałej subskrypcji tematycznej.
- CVE-2026-61487Średnie
Podatność niewłaściwej autoryzacji w Apache ActiveMQ pozwala uwierzytelnionemu użytkownikowi z niskimi uprawnieniami na ominięcie listy ACL zapisu dla docelowych kolejek poprzez wysłanie wiadomości do tymczasowej złożonej kolejki. Sprawia to, że sprawdzenie autoryzacji jest pomijane.
- CVE-2026-59878Wysokie
Apache ActiveMQ (wersje przed 5.19.9 oraz 6.0.0 przed 6.2.8) zawiera podatność w komponencie AMQP NIO. Zdalny, nieuwierzytelniony atakujący może wysłać ramkę z określonym rozmiarem, powodując śmierć wątków NIO. Szybkie powtarzanie może wyczerpać pulę wątków NIO, prowadząc do odmowy usługi.
- CVE-2026-54475Wysokie
W Apache ActiveMQ wykryto brak autoryzacji dla tymczasowych kolejek. Oczekiwano, że tymczasowe kolejki będą izolowane dla połączenia, które je utworzyło, jednak izolacja ta jest sprawdzana tylko po stronie klienta, co pozwala innemu połączeniu na konsumpcję z tymczasowej kolejki innego połączenia.
- CVE-2026-53917Wysokie
Podatność w Apache ActiveMQ pozwala uwierzytelnionemu użytkownikowi na przeprowadzenie ataku DoS na broker poprzez wysłanie spreparowanej wiadomości OpenWire z zawyżoną wartością rozmiaru mapy. Brak walidacji rozmiaru podczas deserializacji map właściwości wiadomości może prowadzić do wyczerpania pamięci (OOM) i awarii brokera.
- CVE-2026-53916Wysokie
Podatność w Apache ActiveMQ pozwala nieuwierzytelnionemu klientowi na wysłanie przez STOMP NIO nagłówków, które nigdy się nie kończą, co powoduje nieograniczone buforowanie przez brokera i wyczerpanie sterty JVM.
Oryginalny opis (angielski, źródło NVD)
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. An authenticated attacker can show malicious content when browsing queues in the web console by overriding the content type to be HTML (instead of XML) and by injecting HTML into a JMS selector field. This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Web: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

