CVE Catalog

CVE-2026-41043

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.56%

46th percentile - higher than 46% of all known CVEs

Summary

Apache ActiveMQ and ActiveMQ Web contain a Basic XSS vulnerability due to improper neutralization of script-related HTML tags in the web console. An authenticated attacker can display malicious content while browsing queues by overriding the content type to HTML and injecting HTML into a JMS selector field. Affects versions before 5.19.6 and 6.0.0 before 6.2.5.

Risk Assessment

An authenticated attacker can execute script in other console users' browsers, potentially leading to session theft or actions on their behalf. It requires an ActiveMQ account but can escalate privileges.

Recommendation

Upgrade Apache ActiveMQ and ActiveMQ Web to version 6.2.5 or 5.19.6 (or later). Restrict access to the web console to trusted networks.

Other vulnerabilities in Apache ActiveMQ

See all
Original NVD description (English source)

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. An authenticated attacker can show malicious content when browsing queues in the web console by overriding the content type to be HTML (instead of XML) and by injecting HTML into a JMS selector field. This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Web: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS