Katalog CVE

CVE-2026-27820

KrytyczneCVSS 9.8
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.56%

Percentyl 46 - wyżej niż 46% wszystkich znanych CVE

Streszczenie

Biblioteka zlib dla Ruby zawiera przepełnienie bufora w Zlib::GzipReader, gdzie funkcja zstream_buffer_ungets nie zapewnia wystarczającej pojemności bufora przed memmove. Może to prowadzić do uszkodzenia pamięci, gdy długość bufora przekracza pojemność. Podatność naprawiono w wersjach 3.0.1, 3.1.2 i 3.2.3.

Ocena ryzyka

Przetwarzanie złośliwych danych gzip może prowadzić do uszkodzenia pamięci w aplikacji Ruby, potencjalnie umożliwiając wykonanie kodu lub awarię. Wpływa to na integralność i dostępność aplikacji.

Rekomendacja

Zaktualizuj gem zlib do wersji 3.0.1, 3.1.2 lub 3.2.3. Sprawdź aplikacje Ruby przetwarzające niezaufane pliki gzip.

Powiązane podatności

Oryginalny opis (angielski, źródło NVD)

zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS