CVE Catalog

CVE-2026-27820

CriticalCVSS 9.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.56%

46th percentile - higher than 46% of all known CVEs

Summary

The zlib Ruby interface contains a buffer overflow in Zlib::GzipReader where zstream_buffer_ungets fails to guarantee sufficient buffer capacity before memmove. This can lead to memory corruption when the buffer length exceeds capacity. The issue is fixed in versions 3.0.1, 3.1.2, and 3.2.3.

Risk Assessment

Processing malicious gzip data may lead to memory corruption in the Ruby application, potentially enabling code execution or crashes. This affects application integrity and availability.

Recommendation

Upgrade the zlib gem to version 3.0.1, 3.1.2, or 3.2.3. Review Ruby applications that process untrusted gzip files.

Related vulnerabilities

Original NVD description (English source)

zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS