CVE-2026-18394
WysokieCVSS 7.4Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 43 - wyżej niż 43% wszystkich znanych CVE
Streszczenie
W Strands Agents Tools przed wersją 0.8.2 występuje nieprawidłowa autoryzacja w narzędziu http_request, która może pozwolić zdalnym atakującym na uzyskanie poświadczeń skonfigurowanych przez HTTP_REQUEST_TOKEN_CONFIG poprzez nakłonienie LLM do kierowania żądań przez infrastrukturę proxy kontrolowaną przez atakującego.
Ocena ryzyka
Atakujący może przechwycić wrażliwe poświadczenia, co prowadzi do nieautoryzowanego dostępu do chronionych zasobów.
Rekomendacja
Należy zaktualizować Strands Agents Tools do wersji 0.8.2 lub nowszej.
Inne podatności w Strands Agents Tools
Zobacz wszystkie- CVE-2026-115415Średnie
Niewłaściwa neutralizacja danych wejściowych używanych do promptów LLM w narzędziu environment w Strands Agents Tools przed wersją 0.8.6 może pozwolić zdalnym aktorom na uzyskanie w postaci jawnej zmiennych środowiskowych hosta agenta, w tym poświadczeń chmurowych i kluczy API, poprzez spreparowany prompt wyłączający maskowanie sekretów w narzędziu. Aby usunąć problem, należy zaktualizować do wersji 0.8.6 lub nowszej i wymienić poświadczenia, które były obecne w środowisku agentów ładujących narzędzie environment.
- CVE-2026-15746Średnie
W narzędziu elasticsearch_memory pakietu strands-agents-tools wykryto podatność SSRF. Parametry połączenia (es_url, cloud_id, api_key) były kontrolowane przez model językowy, a pominięcie api_key powodowało wysłanie klucza API operatora do dowolnego hosta wskazanego przez LLM.
Oryginalny opis (angielski, źródło NVD)
Incorrect authorization in the http_request tool in Strands Agents Tools before 0.8.2 might allow remote attackers to obtain credentials configured via HTTP_REQUEST_TOKEN_CONFIG by influencing the LLM to route requests through actor-controlled proxy infrastructure. To remediate this issue, users should upgrade to version 0.8.2.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

