CVE Catalog

CVE-2026-18394

HighCVSS 7.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.52%

43th percentile - higher than 43% of all known CVEs

Summary

In Strands Agents Tools before 0.8.2, incorrect authorization in the http_request tool may allow remote attackers to obtain credentials configured via HTTP_REQUEST_TOKEN_CONFIG by influencing the LLM to route requests through attacker-controlled proxy infrastructure.

Risk Assessment

An attacker can intercept sensitive credentials, leading to unauthorized access to protected resources.

Recommendation

Upgrade Strands Agents Tools to version 0.8.2 or later.

Other vulnerabilities in Strands Agents Tools

See all
Original NVD description (English source)

Incorrect authorization in the http_request tool in Strands Agents Tools before 0.8.2 might allow remote attackers to obtain credentials configured via HTTP_REQUEST_TOKEN_CONFIG by influencing the LLM to route requests through actor-controlled proxy infrastructure. To remediate this issue, users should upgrade to version 0.8.2.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS