CVE-2026-120215
NiskieCVSS 3.7Streszczenie
Podatność w pluginie @fastify/cors (wersje 8.2.0–11.3.x) dotyczy aplikacji, które rejestrują plugin z niestandardową opcją onSend. Żądanie preflight CORS (OPTIONS z nagłówkami Origin i Access-Control-Request-Method) powoduje ponowne wejście w pipeline wysyłania odpowiedzi i wyjątek ERR_HTTP_HEADERS_SENT, co może zakończyć proces Node.js, jeśli nie ma globalnego handlera błędów.
Ocena ryzyka
Nieuwierzytelniony zdalny klient może jednym żądaniem preflight wywołać awarię procesu Node.js, powodując niedostępność usługi (DoS). Wpływ ogranicza się do dostępności i wymaga użycia niestandardowej konfiguracji onSend.
Rekomendacja
Zaktualizuj @fastify/cors do wersji 11.4.0 lub nowszej, w której onSend nie jest już akceptowaną opcją hooka. Jako obejście użyj innego hooka (np. domyślnego onRequest) lub ustaw preflight na false.
Powiązane podatności
- CVE-2026-86596Krytyczne
Wtyczka s2Member dla WordPressa w wersjach do 260927 włącznie jest podatna na zdalne wykonanie kodu poprzez parametr 'item_name'. Niedostateczna sanityzacja w funkcji strip_php_tags_deep() usuwa jedynie literalne sekwencje '<?', a późniejsze czyszczenie placeholderów po interpolacji odtwarza poprawny otwieracz '<?php' już po osadzeniu wartości kontrolowanej przez atakującego w szablonie e-mail.
- CVE-2026-97718Krytyczne
W wersji 14.60 serwera Secure Access występuje podatność typu cross-site request forgery (CSRF). Z powodu obejścia mechanizmu kontroli bezpieczeństwa atakujący może zmusić administratora do utworzenia konta pod kontrolą atakującego.
- CVE-2026-116769Krytyczne
W serwerach Secure Access w wersjach od 13.0 do wersji przed 14.61 występuje podatność polegająca na obejściu uwierzytelniania. Atakujący mogą modyfikować ustawienia bezpieczeństwa klienta za pośrednictwem serwera.
- CVE-2026-102435Krytyczne
Wtyczka Ultra Addons for Contact Form 7 dla WordPressa jest podatna na usuwanie dowolnych plików z powodu niewystarczającej walidacji ścieżki w funkcji _getObjAttr we wszystkich wersjach do 3.5.54 włącznie. Nieuwierzytelniony atakujący może usunąć dowolne pliki na serwerze, co może prowadzić do zdalnego wykonania kodu po usunięciu odpowiedniego pliku (np. wp-config.php). Wymaga to aktywnego dodatku PDF Generator i skonfigurowanego formularza Contact Form 7 do generowania PDF.
- CVE-2026-105606Krytyczne
Rozszerzenie Joomla Custom Tables w wersjach poniżej 3.7.8 pozwala nieuwierzytelnionemu atakującemu na przesłanie dowolnego pliku (typu polyglot) z kontrolowanym rozszerzeniem do publicznie dostępnego katalogu tmp. Ścieżka zapisanego pliku jest ujawniana w odpowiedzi, a plik jest domyślnie serwowany jako statyczna treść.
- CVE-2026-105604Krytyczne
Rozszerzenie Joomla DJ-Classifieds w wersjach poniżej 3.11.3 jest podatne na nieuwierzytelnioną iniekcję SQL w wyszukiwarce frontendowej.
- CVE-2026-105603Krytyczne
Rozszerzenie Joomla DJ-Classifieds w wersjach poniżej 3.11.3 pozwala nieuprzywilejowanemu użytkownikowi na przesłanie dowolnego pliku, co prowadzi do pełnego zdalnego wykonania kodu (RCE).
- CVE-2026-88811Krytyczne
Brak filtrowania w meta proxy SUSE Rancher Manager może powodować wyciek przekazanych poświadczeń Rancher do dostawców chmury. Problem dotyczy SUSE Rancher w wersjach 2.15.0–2.15.3, 2.14.0–2.14.7 oraz 2.13.0–2.13.11.
- CVE-2026-105769Krytyczne
kaniko przed wersją 1.25.20 może wysłać token dostępu Microsoft Entra ID (Azure AD) dla Azure Resource Manager do rejestru kontrolowanego przez atakującego. Wynika to z niezakotwiczonego wyrażenia regularnego w pomocniku poświadczeń ACR, które akceptuje nazwy hostów zawierające domeny .azurecr.io, .azurecr.cn, .azurecr.de lub .azurecr.us.
- CVE-2026-94290Krytyczne
Kontroler SUSE Rancher Fleet nie ograniczał wystarczająco, które sekrety kubeconfig może przywoływać obiekt Fleet Cluster. W efekcie zwykły użytkownik mógł zdefiniować klaster w swojej przestrzeni nazw i powiązać go z poświadczeniami administracyjnymi klastra zarządzającego, co pozwalało kontrolerowi zarządzać klastrem zarządzającym w imieniu tego użytkownika z podwyższonymi uprawnieniami. Podatność dotyczy wersji 0.16.0–0.16.3, 0.15.0–0.15.8, 0.14.0–0.14.12, 0.13.0–0.13.17 i prawdopodobnie starszych.
Oryginalny opis (angielski, źródło NVD)
@fastify/cors is the CORS plugin for the Fastify web framework. In versions 8.2.0 through 11.3.x, an application that registers the plugin with the non-default onSend hook option crashes on a CORS preflight. On an OPTIONS request that carries the Origin and Access-Control-Request-Method headers, the plugin calls reply.send from inside the onSend hook and re-enters the send pipeline, so a second write of the response headers throws an uncaught ERR_HTTP_HEADERS_SENT that can terminate the Node.js process when no process-level handler is installed. An unauthenticated remote client can trigger this with a single preflight request, so the impact is availability only, and exploitation requires the non-default onSend configuration. The issue is fixed in @fastify/cors 11.4.0, where onSend is no longer an accepted hook value and registration fails with a clear error instead of crashing at request time, and users should upgrade to 11.4.0 or later. As a workaround, use any other hook such as the default onRequest, or set preflight to false.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

