CVE Catalog

CVE-2026-120215

LowCVSS 3.7
Published: Translated: NVD NIST

Summary

@fastify/cors is the CORS plugin for the Fastify web framework. In versions 8.2.0 through 11.3.x, an application that registers the plugin with the non-default onSend hook option crashes on a CORS preflight. On an OPTIONS request carrying the Origin and Access-Control-Request-Method headers, the plugin calls reply.send from inside the onSend hook and re-enters the send pipeline, so a second write of the response headers throws an uncaught ERR_HTTP_HEADERS_SENT that can terminate the Node.js process when no process-level handler is installed.

Risk Assessment

An unauthenticated remote client can trigger a Node.js process crash with a single preflight request, causing a denial of service (availability impact only). Exploitation requires the non-default onSend configuration.

Recommendation

Upgrade @fastify/cors to 11.4.0 or later, where onSend is no longer an accepted hook value and registration fails with a clear error instead of crashing at request time. As a workaround, use any other hook such as the default onRequest, or set preflight to false.

Related vulnerabilities

Original NVD description (English source)

@fastify/cors is the CORS plugin for the Fastify web framework. In versions 8.2.0 through 11.3.x, an application that registers the plugin with the non-default onSend hook option crashes on a CORS preflight. On an OPTIONS request that carries the Origin and Access-Control-Request-Method headers, the plugin calls reply.send from inside the onSend hook and re-enters the send pipeline, so a second write of the response headers throws an uncaught ERR_HTTP_HEADERS_SENT that can terminate the Node.js process when no process-level handler is installed. An unauthenticated remote client can trigger this with a single preflight request, so the impact is availability only, and exploitation requires the non-default onSend configuration. The issue is fixed in @fastify/cors 11.4.0, where onSend is no longer an accepted hook value and registration fails with a clear error instead of crashing at request time, and users should upgrade to 11.4.0 or later. As a workaround, use any other hook such as the default onRequest, or set preflight to false.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS