Katalog CVE

CVE-2026-112945

NiskieCVSS 2.1
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Podwyższone ryzyko
0.67%

Percentyl 52 - wyżej niż 52% wszystkich znanych CVE

Streszczenie

W Vite przed wersjami 6.4.4, 7.3.7, 8.1.6, 8.2.4 i 8.3.3 aplikacje używające niestandardowego middleware są podatne, gdy przekazują niezmieniony URL żądania przeglądarki do server.transformIndexHtml. getHtmlFilename używa URL żądania z zapytaniem do rozwiązania istniejącego pliku lokalnego, zachowując wiodące ukośniki dostarczone przez atakującego w wygenerowanym URL modułu proxy. Jeśli przekształcony HTML zawiera wbudowany skrypt modułu, a przeglądarka ofiary ładuje spreparowaną stronę serwera deweloperskiego, wiodący podwójny ukośnik powoduje pobranie i wykonanie modułu kontrolowanego przez atakującego.

Ocena ryzyka

Atakujący może doprowadzić do wykonania złośliwego modułu w przeglądarce ofiary w kontekście strony serwera deweloperskiego Vite. Może to ujawnić wrażliwe dane strony lub umożliwić krytyczne działania dostępne dla aplikacji.

Rekomendacja

Zaktualizuj Vite do wersji 6.4.4, 7.3.7, 8.1.6, 8.2.4 lub 8.3.3 (lub nowszej). Unikaj przekazywania niezmienionego URL żądania przeglądarki do server.transformIndexHtml w niestandardowym middleware.

Inne podatności w Vite

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Vite is a frontend tooling framework for JavaScript. Prior to 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3, applications using custom middleware are vulnerable when they pass an unchanged browser request URL to server.transformIndexHtml. getHtmlFilename uses the query-bearing request URL to resolve an existing local file while preserving attacker-supplied leading slashes in the generated proxy module URL. If the transformed HTML contains an inline module script and a victim browser loads the crafted development-server page, the leading double slash makes the browser fetch and execute an attacker-controlled module in the Vite-served page. This execution can expose sensitive page data or permit critical actions available to the affected application. This issue is fixed in versions 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS