CVE Catalog

CVE-2026-112945

LowCVSS 2.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
0.67%

52th percentile - higher than 52% of all known CVEs

Summary

In Vite prior to 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3, applications using custom middleware are vulnerable when they pass an unchanged browser request URL to server.transformIndexHtml. getHtmlFilename uses the query-bearing request URL to resolve an existing local file while preserving attacker-supplied leading slashes in the generated proxy module URL. If the transformed HTML contains an inline module script and a victim browser loads the crafted development-server page, the leading double slash makes the browser fetch and execute an attacker-controlled module.

Risk Assessment

An attacker can cause execution of a malicious module in the victim's browser within the context of the Vite development server page. This may expose sensitive page data or permit critical actions available to the application.

Recommendation

Upgrade Vite to version 6.4.4, 7.3.7, 8.1.6, 8.2.4, or 8.3.3 (or later). Avoid passing unchanged browser request URLs to server.transformIndexHtml in custom middleware.

Other vulnerabilities in Vite

See all
Original NVD description (English source)

Vite is a frontend tooling framework for JavaScript. Prior to 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3, applications using custom middleware are vulnerable when they pass an unchanged browser request URL to server.transformIndexHtml. getHtmlFilename uses the query-bearing request URL to resolve an existing local file while preserving attacker-supplied leading slashes in the generated proxy module URL. If the transformed HTML contains an inline module script and a victim browser loads the crafted development-server page, the leading double slash makes the browser fetch and execute an attacker-controlled module in the Vite-served page. This execution can expose sensitive page data or permit critical actions available to the affected application. This issue is fixed in versions 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS