CVE-2025-66200
ŚrednieCVSS 5.4Prawdopodobieństwo exploitacji (EPSS)
Podwyższone ryzykoPercentyl 50 - wyżej niż 50% wszystkich znanych CVE
Streszczenie
W Apache HTTP Server występuje podatność obejścia mod_userdir+suexec poprzez AllowOverride FileInfo. Użytkownicy z dostępem do dyrektywy RequestHeader w htaccess mogą spowodować uruchomienie niektórych skryptów CGI pod nieoczekiwanym identyfikatorem użytkownika. Problem dotyczy wersji od 2.4.7 do 2.4.65.
Ocena ryzyka
Atakujący może wykorzystać tę lukę do uruchomienia skryptów CGI z uprawnieniami innego użytkownika, co może prowadzić do eskalacji uprawnień i nieautoryzowanego dostępu do zasobów.
Rekomendacja
Zaktualizuj Apache HTTP Server do wersji 2.4.66, która naprawia tę podatność.
Inne podatności w Apache HTTP Server
Zobacz wszystkie- CVE-2017-9798Wysokie
Apache httpd pozwala zdalnym atakującym na odczytanie tajnych danych z pamięci procesu, jeśli dyrektywa Limit może być ustawiona w pliku .htaccess użytkownika lub jeśli httpd.conf ma określone błędne konfiguracje. Problem ten dotyczy serwera Apache HTTP w wersjach do 2.2.34 oraz 2.4.x do 2.4.27.
- CVE-2016-8743Wysokie
Serwer Apache HTTP w wersjach przed 2.2.32 i 2.4.25 akceptował zbyt liberalnie białe znaki w żądaniach oraz w liniach odpowiedzi i nagłówkach. Taka akceptacja różnych zachowań stanowiła zagrożenie bezpieczeństwa, gdy httpd uczestował w łańcuchu proxy lub współpracował z serwerami aplikacyjnymi.
- CVE-2016-5387Wysokie
Serwer Apache HTTP w wersjach do 2.4.23 nie chroni aplikacji przed nieufnymi danymi klienta w zmiennej środowiskowej HTTP_PROXY, co może umożliwić zdalnym atakującym przekierowanie ruchu HTTP aplikacji do dowolnego serwera proxy za pomocą spreparowanego nagłówka Proxy w żądaniu HTTP.
- CVE-2016-4979Wysokie
Serwer Apache HTTP w wersjach od 2.4.18 do 2.4.20, przy włączonych mod_http2 i mod_ssl, nieprawidłowo rozpoznaje dyrektywę 'SSLVerifyClient require' dla autoryzacji żądań HTTP/2. To pozwala zdalnym atakującym na obejście zamierzonych ograniczeń dostępu.
- CVE-2024-40725Średnie
Częściowa poprawka dla CVE-2024-39884 w Apache HTTP Server 2.4.61 nie uwzględnia pewnych konfiguracji opartych na typie treści, takich jak AddType. W określonych okolicznościach, gdy pliki są żądane pośrednio, może dojść do ujawnienia kodu źródłowego lokalnej treści.
- CVE-2024-36387Średnie
Obsługa uaktualnień protokołu WebSocket przez połączenie HTTP/2 może skutkować dereferencją wskaźnika null, prowadzącą do awarii procesu serwera i degradacji wydajności.
- CVE-2024-38477Średnie
W module mod_proxy Apache HTTP Server 2.4.59 i wcześniejszych występuje dereferencja wskaźnika null, która pozwala atakującemu na spowodowanie awarii serwera za pomocą złośliwego żądania.
- CVE-2023-38709Średnie
W rdzeniu Apache HTTP Server do wersji 2.4.58 występuje wadliwa walidacja wejścia, która pozwala złośliwym lub podatnym na ataki backendom lub generatorom treści na dzielenie odpowiedzi HTTP. Może to prowadzić do ataków typu HTTP response splitting.
- CVE-2024-24795Średnie
W wielu modułach Apache HTTP Server występuje podatność na dzielenie odpowiedzi HTTP (HTTP Response Splitting). Atakujący, który może wstrzyknąć złośliwe nagłówki odpowiedzi do aplikacji backendowych, może spowodować atak desynchronizacji HTTP.
- CVE-2024-27316Średnie
W Apache HTTP Server, przychodzące nagłówki HTTP/2 przekraczające limit są tymczasowo buforowane w nghttp2 w celu wygenerowania informacyjnej odpowiedzi HTTP 413. Jeśli klient nie przestanie wysyłać nagłówków, prowadzi to do wyczerpania pamięci.
Oryginalny opis (angielski, źródło NVD)
mod_userdir+suexec bypass via AllowOverride FileInfo vulnerability in Apache HTTP Server. Users with access to use the RequestHeader directive in htaccess can cause some CGI scripts to run under an unexpected userid. This issue affects Apache HTTP Server: from 2.4.7 through 2.4.65. Users are recommended to upgrade to version 2.4.66, which fixes the issue.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

