Katalog CVE

CVE-2025-59302

ŚrednieCVSS 4.7
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.46%

Percentyl 38 - wyżej niż 38% wszystkich znanych CVE

Streszczenie

W Apache CloudStack występuje podatność typu code injection w API dostępnych wyłącznie dla administratorów: quotaTariffCreate, quotaTariffUpdate, createSecondaryStorageSelector, updateSecondaryStorageSelector, updateHost i updateStorage. Problem dotyczy wersji od 4.18.0 przed 4.20.2 oraz od 4.21.0 przed 4.22.0.

Ocena ryzyka

Administrator może wstrzyknąć kod, co może prowadzić do wykonania nieautoryzowanych operacji w systemie. Ryzyko jest ograniczone do kont administracyjnych, ale może skutkować poważnym naruszeniem bezpieczeństwa.

Rekomendacja

Zaktualizuj Apache CloudStack do wersji 4.20.2 lub 4.22.0. Rozważ ustawienie flagi js.interpretation.enabled w celu kontroli interpretacji wyrażeń JavaScript w tych API.

Inne podatności w Apache CloudStack

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

In Apache CloudStack improper control of generation of code ('Code Injection') vulnerability is found in the following APIs which are accessible only to admins. * quotaTariffCreate * quotaTariffUpdate * createSecondaryStorageSelector * updateSecondaryStorageSelector * updateHost * updateStorage This issue affects Apache CloudStack: from 4.18.0 before 4.20.2, from 4.21.0 before 4.22.0. Users are recommended to upgrade to versions 4.20.2 or 4.22.0, which contain the fix. The fix introduces a new global configuration flag, js.interpretation.enabled, allowing administrators to control the interpretation of JavaScript expressions in these APIs, thereby mitigating the code injection risk.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS