Katalog CVE

CVE-2025-57752

ŚrednieCVSS 6.2
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Niskie ryzyko
0.35%

Percentyl 27 - wyżej niż 27% wszystkich znanych CVE

Streszczenie

Next.js w wersjach przed 14.2.31 oraz 15.0.0–15.4.5 ma podatność cache key confusion w API optymalizacji obrazów. Odpowiedzi z tras API zależne od nagłówków żądań (np. Cookie, Authorization) mogą być błędnie buforowane i serwowane nieuprawnionym użytkownikom.

Ocena ryzyka

Nieuprawniony użytkownik może otrzymać obrazy lub treści przeznaczone dla innego użytkownika, co grozi wyciekiem danych i naruszeniem poufności.

Rekomendacja

Zaktualizuj Next.js do wersji 14.2.31 lub 15.4.5 (lub nowszej), zwłaszcza jeśli trasy API serwują obrazy zależne od nagłówków żądań.

Inne podatności w Next.js

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization API routes are affected by cache key confusion. When images returned from API routes vary based on request headers (such as Cookie or Authorization), these responses could be incorrectly cached and served to unauthorized users due to a cache key confusion bug. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5. All users are encouraged to upgrade if they use API routes to serve images that depend on request headers and have image optimization enabled.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS