CVE Catalog

CVE-2025-57752

MediumCVSS 6.2
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.35%

27th percentile - higher than 27% of all known CVEs

Summary

Next.js before 14.2.31 and 15.0.0 to before 15.4.5 is affected by cache key confusion in the Image Optimization API routes. Responses from API routes that vary by request headers (e.g., Cookie or Authorization) could be incorrectly cached and served to unauthorized users.

Risk Assessment

An unauthorized user could receive images or content intended for another user, risking data leakage and confidentiality breaches.

Recommendation

Upgrade Next.js to 14.2.31 or 15.4.5 (or later), especially if API routes serve images that depend on request headers.

Other vulnerabilities in Next.js

See all
Original NVD description (English source)

Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization API routes are affected by cache key confusion. When images returned from API routes vary based on request headers (such as Cookie or Authorization), these responses could be incorrectly cached and served to unauthorized users due to a cache key confusion bug. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5. All users are encouraged to upgrade if they use API routes to serve images that depend on request headers and have image optimization enabled.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS