Katalog CVE

CVE-2024-45409

KrytyczneCVSS 10.0
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Bardzo wysokie ryzyko
10.68%

Percentyl 96 - wyżej niż 96% wszystkich znanych CVE

Streszczenie

Biblioteka Ruby SAML (ruby-saml) w wersjach <= 12.2 oraz 1.13.0–1.16.0 nieprawidłowo weryfikuje podpis odpowiedzi SAML. Uwierzytelniony atakujący z dostępem do dowolnego podpisanego dokumentu SAML (od IdP) może sfałszować odpowiedź/asercję SAML o dowolnej treści i zalogować się jako dowolny użytkownik.

Ocena ryzyka

Możliwe przejęcie konta dowolnego użytkownika w systemie korzystającym z podatnej biblioteki, w tym kont administracyjnych, co może prowadzić do pełnego naruszenia systemu.

Rekomendacja

Zaktualizuj bibliotekę ruby-saml do wersji 1.17.0 lub 1.12.3 (lub nowszej) i przejrzyj logi uwierzytelniania SAML pod kątem podejrzanych zdarzeń.

Inne podatności w Ruby SAML

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS