CVE Catalog

CVE-2024-45409

CriticalCVSS 10.0
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Very high risk
10.68%

96th percentile - higher than 96% of all known CVEs

Summary

The Ruby SAML library (ruby-saml) in versions <= 12.2 and 1.13.0 through 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed SAML document (from the IdP) can forge a SAML Response/Assertion with arbitrary contents and log in as any user.

Risk Assessment

Potential takeover of any user account in systems using the vulnerable library, including administrative accounts, which may lead to full system compromise.

Recommendation

Update ruby-saml to version 1.17.0 or 1.12.3 (or later) and review SAML authentication logs for suspicious activity.

Other vulnerabilities in Ruby SAML

See all
Original NVD description (English source)

The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS