Katalog CVE

CVE-2024-25621

WysokieCVSS 7.3
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Streszczenie

containerd w wersjach od 0.1.0 do 1.7.28, od 2.0.0-beta.0 do 2.0.6, od 2.1.0-beta.0 do 2.1.4 oraz od 2.2.0-beta.0 do 2.2.0-rc.1 ma podatność związaną z nadmiernie szerokimi domyślnymi uprawnieniami. Katalogi /var/lib/containerd, /run/containerd/io.containerd.grpc.v1.cri oraz /run/containerd/io.containerd.sandbox.controller.v1.shim są tworzone z nieprawidłowymi uprawnieniami.

Ocena ryzyka

Może to umożliwić nieautoryzowanym użytkownikom dostęp do wrażliwych danych lub wykonanie niepożądanych operacji w środowisku kontenerowym. Ryzyko dotyczy hostów z zainstalowanym containerd.

Rekomendacja

Zaktualizuj containerd do wersji 1.7.29, 2.0.7, 2.1.5 lub 2.2.0. Jako obejście, zmień uprawnienia katalogów ręcznie (chmod) lub uruchom containerd w trybie rootless.

Inne podatności w containerd

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS