CVE Catalog

CVE-2024-25621

HighCVSS 7.3
Published: Updated: Translated: NVD NIST

Summary

containerd versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4, and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directories /var/lib/containerd, /run/containerd/io.containerd.grpc.v1.cri, and /run/containerd/io.containerd.sandbox.controller.v1.shim are created with incorrect permissions.

Risk Assessment

This may allow unauthorized users to access sensitive data or perform unwanted operations in the container environment. The risk affects hosts with containerd installed.

Recommendation

Update containerd to version 1.7.29, 2.0.7, 2.1.5, or 2.2.0. As a workaround, manually change directory permissions (chmod) or run containerd in rootless mode.

Other vulnerabilities in containerd

See all
Original NVD description (English source)

containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS