Katalog CVE

CVE-2023-2017

WysokieCVSS 8.8
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Wysokie ryzyko
2.07%

Percentyl 81 - wyżej niż 81% wszystkich znanych CVE

Streszczenie

W Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 do v6.5.0.0-rc4) występuje Server-Side Template Injection (SSTI) w shopware/core i shopware/platform. Zdalny atakujący z dostępem do środowiska Twig bez rozszerzenia Sandbox może ominąć kontrole w Shopware\Core\Framework\Adapter\Twig\SecurityExtension i wywołać dowolną funkcję PHP, a tym samym wykonać dowolny kod lub polecenia. Podatność omija CVE-2023-22731.

Ocena ryzyka

Atakujący może wykonać dowolny kod lub polecenia na serwerze, co może prowadzić do pełnego przejęcia systemu i wycieku danych.

Rekomendacja

Zaktualizuj Shopware do wersji v6.4.20.1 lub nowszej, która rozwiązuje ten problem.

Inne podatności w Shopware

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validation checks in `Shopware\Core\Framework\Adapter\Twig\SecurityExtension` and call any arbitrary PHP function and thus execute arbitrary code/commands via usage of fully-qualified names, supplied as array of strings, when referencing callables. Users are advised to upgrade to v6.4.20.1 to resolve this issue. This is a bypass of CVE-2023-22731.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS