CVE Catalog

CVE-2023-2017

HighCVSS 8.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

High risk
2.07%

81th percentile - higher than 81% of all known CVEs

Summary

Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 to v6.5.0.0-rc4) affects both shopware/core and shopware/platform. A remote attacker with access to a Twig environment without the Sandbox extension can bypass checks in Shopware\Core\Framework\Adapter\Twig\SecurityExtension and call any arbitrary PHP function, thus executing arbitrary code or commands. This is a bypass of CVE-2023-22731.

Risk Assessment

An attacker can execute arbitrary code or commands on the server, potentially leading to full system compromise and data leakage.

Recommendation

Upgrade Shopware to version v6.4.20.1 or later, which resolves this issue.

Other vulnerabilities in Shopware

See all
Original NVD description (English source)

Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validation checks in `Shopware\Core\Framework\Adapter\Twig\SecurityExtension` and call any arbitrary PHP function and thus execute arbitrary code/commands via usage of fully-qualified names, supplied as array of strings, when referencing callables. Users are advised to upgrade to v6.4.20.1 to resolve this issue. This is a bypass of CVE-2023-22731.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS