CVE Catalog

CVE-2026-85241

MediumCVSS 6.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.27%

19th percentile - higher than 19% of all known CVEs

Summary

A weakness has been identified in SpecterOps BloodHound up to 9.5.1. The affected element is the function NewV2API of the file cmd/api/src/api/registration/v2.go of the component Graph Write Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. Upgrading to version 9.6.0-rc1, 9.6.0 and 9.7.0-rc3 is sufficient to fix this issue.

Risk Assessment

The risk includes potential unauthorized access to graph write functionality, which could lead to data manipulation or privilege escalation in the BloodHound environment.

Recommendation

It is recommended to upgrade BloodHound to version 9.6.0-rc1, 9.6.0, or 9.7.0-rc3 that includes the fix. Also, monitor logs for unauthorized access attempts.

Related vulnerabilities

Original NVD description (English source)

A weakness has been identified in SpecterOps BloodHound up to 9.5.1. The affected element is the function NewV2API of the file cmd/api/src/api/registration/v2.go of the component Graph Write Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. Upgrading to version 9.6.0-rc1, 9.6.0 and 9.7.0-rc3 is sufficient to fix this issue. This patch is called 39d1276a63e95a7713f954dea632a19651d9cebb. You should upgrade the affected component.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS