Apache Answer vulnerabilities
26 known CVE vulnerabilities in Apache Answer, translated and rated.
- CVE-2026-90910Critical
Apache Answer through 2.0.2 has a missing authentication for critical function vulnerability. The reaction API did not enforce content visibility controls, allowing unauthorized users to read reaction metadata from restricted content or add and remove their own reactions.
- CVE-2026-60053Critical
Apache Answer through version 2.0.1 has insufficient session expiration: administrative API keys remain usable after the owning administrator is demoted or the account is marked inactive, suspended, or deleted, allowing continued access until the keys are explicitly removed.
- CVE-2026-86589Medium
Apache Answer through 2.0.2 has an incorrect implementation of authentication algorithm vulnerability. A flaw in the User Center login integration can cause a newly created external user session to omit its external identity, allowing subsequent requests to bypass central account suspension or deletion checks until the session expires or is revoked.
- CVE-2026-79633Low risk· EPSS 10%
Apache Answer through 2.0.2 has a missing authorization checks vulnerability. Authenticated users could perform actions on non-public content they were not permitted to access.
- CVE-2026-79624Low risk· EPSS 10%
Apache Answer through 2.0.2 has an insufficient session expiration vulnerability. Insufficient session invalidation allowed revoked users to continue accessing known private uploaded files with a stale visit token.
- CVE-2026-79620Low risk· EPSS 10%
Apache Answer through 2.0.2 has an exposure of sensitive information through data queries vulnerability. An improper authorization check in the similar-question search allowed authenticated users to view metadata of non-public questions.
- CVE-2026-79613Low risk· EPSS 6%
In Apache Answer through 2.0.2, unauthenticated attackers could access comments associated with non-public content through public user profiles. The flaw stems from insufficient visibility checks on comments.
- CVE-2026-76994Low risk· EPSS 7%
In Apache Answer through 2.0.2, unauthenticated attackers could obtain metadata associated with hidden questions through public answer profiles. This is an exposure of sensitive information to unauthorized actors.
- CVE-2026-71563Medium
In Apache Answer through 2.0.2, an authorization flaw in the MCP answer retrieval tool allows holders of a global API key to access answer content associated with hidden, deleted, or pending-review questions.
- CVE-2026-68482Medium
In Apache Answer through 2.0.2, an unauthenticated or unauthorized user can retrieve the invited-user list associated with a non-public question due to missing visibility authorization checks.
- CVE-2026-67249Medium
In Apache Answer through 2.0.2, a verification code issued for one email-based workflow could be accepted by another sensitive workflow because the code purpose was not properly enforced.
- CVE-2026-64945Low risk· EPSS 10%
In Apache Answer through 2.0.2, the question operation controller gates hide/show operations on the wrong permission check (unpin instead of hide). In custom role configurations separating these permissions, a user granted only question.unpin can hide or restore questions without holding question.hide or question.show.
- CVE-2026-64944Low risk· EPSS 11%
In Apache Answer through 2.0.2, the importer stores imported question bodies as raw HTML without passing them through the normal Markdown-to-HTML sanitization path. Attacker-controlled HTML embedded in an imported data source is persisted and rendered to all viewers, including privileged users, as stored XSS.
- CVE-2026-64943High
In Apache Answer through 2.0.2, full API keys are written to application logs on every authenticated request, allowing anyone with log-read access to recover and replay active bearer credentials.
- CVE-2026-60023High
Apache Answer through version 2.0.1 has a vulnerability exposing sensitive information: deleted or pending answers can be retrieved by unauthorized users through the single-answer read path when the parent question remains visible.
- CVE-2026-50749Medium
Apache Answer through version 2.0.1 has an improper authorization vulnerability: any authenticated user can reject arbitrary pending edit-revisions without review permission due to a missing authorization check on the reject operation.
- CVE-2026-48912Medium
Apache Answer through version 2.0.1 has an improper input validation vulnerability: a missing ownership check in the avatar-cleanup logic allows any authenticated user to delete other users' uploaded files by supplying their file URLs.
- CVE-2026-48911High
Apache Answer through version 2.0.1 has an insufficient verification of data authenticity vulnerability: a missing authorization check in the external-login email binding flow allows unauthenticated attackers to take over arbitrary user accounts by tricking victims into clicking a crafted confirmation link.
- CVE-2026-48834High
Apache Answer through version 2.0.1 has an improper handling of length parameter inconsistency vulnerability: unauthenticated attackers can cause a denial of service via a specially crafted Accept-Language header that triggers excessive CPU consumption during parsing.
- CVE-2026-25700High
CVE-2026-25700 describes an improper restriction of security token assignment vulnerability in Apache Answer up to version 2.0.0. Previously issued administrative tokens were not invalidated after an administrator account was suspended, deleted, or deactivated, allowing continued access to administrative APIs until the token expired.
- CVE-2026-34905Medium
Apache Answer up to version 2.0.0 did not enforce access restrictions on direct API endpoints for unlisted questions. Authenticated users could discover and view such questions, answers, comments, and revision history.
- CVE-2026-34033Medium
Apache Answer through version 2.0.0 has an XSS vulnerability because user-supplied content is included in notification emails without proper escaping. An authenticated user can inject arbitrary HTML into emails sent to other users.
- CVE-2026-34031Medium
In Apache Answer up to version 2.0.0, there is an unrestricted file upload vulnerability with dangerous type. The server did not sufficiently validate user-supplied image URLs, allowing arbitrary external content to be embedded as profile images.
- CVE-2026-33582Medium
Apache Answer up to version 2.0.0 has an unrestricted file upload vulnerability. A crafted TIFF image can trigger excessive memory allocation during decoding, causing a server crash. Authentication is required.
- CVE-2026-25699Medium
Exposure of Private Personal Information to an Unauthorized Actor vulnerability in Apache Answer. Affects versions through 2.0.0. Timeline-related APIs lacked proper authorization checks, allowing regular authenticated users to access deleted, private, or unapproved content and its revision history. Users are recommended to upgrade to version 2.0.1.
- CVE-2026-25688Medium
Improper Neutralization of Alternate XSS Syntax vulnerability in Apache Answer. Affects versions through 2.0.0. AI-generated response content was rendered in the browser without proper sanitization, allowing malicious scripts to be executed when the content was viewed. Users are recommended to upgrade to version 2.0.1.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

