CVE Catalog

CVE-2026-24098

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
0.83%

58th percentile - higher than 58% of all known CVEs

Summary

Apache Airflow versions 3.0.0 through 3.1.7 allow authenticated UI users with permission to specific DAGs to view import errors generated by other DAGs they are not authorized to access.

Risk Assessment

Users may gain information about the structure and errors of DAGs they should not see, potentially aiding further attacks or revealing sensitive data.

Recommendation

Upgrade Apache Airflow to version 3.1.7 or later.

Other vulnerabilities in Apache Airflow

See all
Original NVD description (English source)

Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this issue

Vulnerability data from NVD (NIST) · CISA KEV · EPSS