CVE Catalog

CVE-2025-6227

LowCVSS 2.2
Published: Updated: Translated: NVD NIST

Summary

Mattermost versions 10.5.x <= 10.5.7, 9.11.x <= 9.11.16 fail to negotiate a new token when accepting the invite which allows a user that intercepts both invite and password to send synchronization payloads to the server that originally created the invite via the REST API.

Risk Assessment

An attacker who can intercept both the invite and password may send unauthorized synchronization payloads, potentially leading to data integrity breaches or unauthorized actions on behalf of the user. The risk affects confidentiality and integrity.

Recommendation

Update Mattermost to a version later than 10.5.7 or 9.11.16. Implement strong protection for invites and passwords, such as encryption and monitoring for suspicious activity.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 10.5.x <= 10.5.7, 9.11.x <= 9.11.16 fail to negotiate a new token when accepting the invite which allows a user that intercepts both invite and password to send synchronization payloads to the server that originally created the invite via the REST API.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS