CVE Catalog

CVE-2025-25279

CriticalCVSS 9.9
Published: Updated: Translated: NVD NIST

Summary

In Mattermost versions 10.4.x <= 10.4.1, 9.11.x <= 9.11.7, 10.3.x <= 10.3.2 and 10.2.x <= 10.2.2, board blocks are not properly validated during board import. An attacker can read any arbitrary file on the system by importing and exporting a specially crafted import archive in Boards.

Risk Assessment

An attacker can access arbitrary files on the server, potentially exposing sensitive data, configuration and secrets.

Recommendation

Update Mattermost to a version later than 10.4.1, 9.11.7, 10.3.2 or 10.2.2 that contains the board import validation fix.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 10.4.x <= 10.4.1, 9.11.x <= 9.11.7, 10.3.x <= 10.3.2, 10.2.x <= 10.2.2 fail to properly validate board blocks when importing boards which allows an attacker could read any arbitrary file on the system via importing and exporting a specially crafted import archive in Boards.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS