CVE Catalog

CVE-2025-24839

LowCVSS 3.1
Published: Updated: Translated: NVD NIST

Summary

Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, and 9.11.x <= 9.11.9 fail to prevent Wrangler posts from triggering AI responses. A user without access to the AI bot can activate it by attaching the activate_ai override property to a post via the Wrangler plugin, provided both the AI and Wrangler plugins are enabled.

Risk Assessment

Unauthorized users can trigger AI functions, potentially leading to uncontrolled resource consumption or information disclosure.

Recommendation

Update Mattermost to a version later than 10.5.1, 10.4.3, or 9.11.9. If updating is not possible, consider disabling the Wrangler or AI plugin.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to prevent Wrangler posts from triggering AI responses. This vulnerability allows users without access to the AI bot to activate it by attaching the activate_ai override property to a post via the Wrangler plugin, provided both the AI and Wrangler plugins are enabled.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS