CVE Catalog

CVE-2025-20051

CriticalCVSS 9.9
Published: Updated: Translated: NVD NIST

Summary

In Mattermost versions 10.4.x <= 10.4.1, 9.11.x <= 9.11.7, 10.3.x <= 10.3.2 and 10.2.x <= 10.2.2, input is not properly validated when patching and duplicating a board. A user can read any arbitrary file on the system by duplicating a specially crafted block in Boards.

Risk Assessment

A user can read arbitrary files on the server, potentially leading to disclosure of sensitive data and configuration.

Recommendation

Update Mattermost to a version later than 10.4.1, 9.11.7, 10.3.2 or 10.2.2 that contains the Boards input validation fix.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 10.4.x <= 10.4.1, 9.11.x <= 9.11.7, 10.3.x <= 10.3.2, 10.2.x <= 10.2.2 fail to properly validate input when patching and duplicating a board, which allows a user to read any arbitrary file on the system via duplicating a specially crafted block in Boards.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS