CVE Catalog

CVE-2025-13870

LowCVSS 3.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.22%

12th percentile - higher than 12% of all known CVEs

Summary

Mattermost versions 10.11.x <= 10.11.4 and 10.5.x <= 10.5.12 fail to validate user permissions when accessing files and subscribing to blocks in Boards. An authenticated user can access files from other boards and subscribe to blocks from boards they do not have access to.

Risk Assessment

An authenticated user could unauthorizedly view files and subscribe to blocks from other boards, potentially leading to leakage of sensitive information. This violates access control and could result in data disclosure.

Recommendation

Update Mattermost to a version later than 10.11.4 or 10.5.12. Conduct an audit of user permissions and verify that board access is properly restricted.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to validate the user permission when accessing the files and subscribing to the block in Boards, which allows an authenticated user to access other board files and was able to subscribe to the block from other boards that the user does not have access to

Vulnerability data from NVD (NIST) · CISA KEV · EPSS