CVE Catalog

CVE-2024-50052

MediumCVSS 4.3
Published: Updated: Translated: NVD NIST

Summary

Mattermost versions 9.10.x <= 9.10.2, 9.11.x <= 9.11.1, and 9.5.x <= 9.5.9 fail to check that the origin of the message in an integration action matches the original post metadata. An authenticated user can delete an arbitrary post.

Risk Assessment

An authenticated user can delete arbitrary posts, leading to data loss and breach of communication integrity.

Recommendation

Update Mattermost to a patched version (e.g., 9.10.3, 9.11.2, 9.5.10 or later).

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 9.10.x <= 9.10.2, 9.11.x <= 9.11.1, 9.5.x <= 9.5.9 fail to check that the origin of the message in an integration action matches with the original post metadata which allows an authenticated user to delete an arbitrary post.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS