CVE Catalog

CVE-2024-41926

LowCVSS 2.7
Published: Updated: Translated: NVD NIST

Summary

Mattermost versions 9.9.x <= 9.9.0 and 9.5.x <= 9.5.6 fail to validate the source of sync messages and only allow the correct remote IDs, which allows a malicious remote to set arbitrary RemoteId values for synced users and therefore claim that a user was synced from another remote.

Risk Assessment

An attacker can impersonate another remote server and mislead the sync system, potentially leading to incorrect user assignment or privilege escalation.

Recommendation

Update Mattermost to a version later than 9.9.0 or 9.5.6. Monitor sync logs for unusual RemoteId values.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 9.9.x <= 9.9.0 and 9.5.x <= 9.5.6 fail to validate the source of sync messages and only allow the correct remote IDs, which allows a malicious remote to set arbitrary RemoteId values for synced users and therefore claim that a user was synced from another remote.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS