CVE-2023-34093
MediumCVSS 4.8Exploitation Probability (EPSS)
Low risk44th percentile - higher than 44% of all known CVEs
Summary
Strapi, an open-source content management system, prior to version 4.10.8 allowed anyone to make content-type attributes public without realizing it. This vulnerability could lead to sensitive information being exposed as users might unknowingly remove the privateAttributes protection mechanism.
Risk Assessment
Organizations may be at risk of sensitive data exposure or system takeover by an attacker gaining access to password hashes. The potential risk affects all users who modify or extend content types.
Recommendation
It is recommended to upgrade to version 4.10.8, which includes a patch for this vulnerability. Users should also be cautious about how they modify content types to avoid unintended attribute exposure.
Other vulnerabilities in Strapi
See all- CVE-2026-27886High
Strapi is an open-source content management system that in versions from 4.0.0 to prior to 5.37.0 did not sufficiently sanitize query parameters when filtering content via relational fields. An unauthenticated attacker could use the `where` query parameter to perform a boolean-oracle attack against private fields in the `admin_users` table, allowing for administrative account takeover.
- CVE-2023-22894MediumActively exploited
Strapi through 4.5.5 allows attackers with admin panel access to discover sensitive user details by exploiting the query filter. Attackers can filter users by columns containing sensitive information and infer values from API responses. Super admin can discover password hashes and password reset tokens of all users.
- CVE-2026-108114Medium
Strapi versions 5.47.0 through 5.57.0 contain an improper authorization vulnerability that allows admin API tokens to retain all-field Content Manager access after the owner's role is field-restricted. Because reconcileTokenPermissionsToUserCeiling ignores token permissions with omitted or null fields, token holders can keep reading content fields an administrator removed from the role.
- CVE-2026-90561High
Strapi versions 4.x through 4.26.2 and 5.x before 5.48.1 contain a stored cross-site scripting vulnerability in the content manager WYSIWYG preview component that fails to strip script tags from rich text. An Author-role user can store malicious script tags in rich text fields that execute in an Editor or Super Admin's session when the preview pane is expanded, enabling account takeover.
- CVE-2026-57997Medium
The Strapi users-permissions plugin fails to restrict JWT algorithms when plugin::users-permissions.jwt.algorithm is not explicitly configured, allowing acceptance of HS384 and HS512 tokens alongside HS256. Attackers possessing the jwtSecret can mint tokens with non-standard HMAC variants to bypass algorithm restrictions and weaken authentication controls.
- CVE-2026-22707Medium
In Strapi versions prior to 5.33.3, the Upload plugin's Content API endpoints did not enforce administrator-configured MIME type restrictions. An authenticated user with Content API upload permission could upload disallowed file types, including HTML and SVG, potentially leading to admin session hijack in default deployments.
- CVE-2026-22706Medium
In Strapi prior to 5.33.3, changing or resetting a user's password did not invalidate existing refresh-token sessions by default, because the invalidation step depended on a caller-supplied deviceId. An attacker with a previously obtained refresh token could continue minting new access tokens after the legitimate user reset their password, maintaining unauthorized access for up to 30 days. The patch in 5.33.3 invalidates all refresh tokens on every password change and reset.
- CVE-2026-22599High
In Strapi (4.x before 4.26.1 and 5.x before 5.33.2), an authenticated administrator could inject arbitrary SQL statements through the `column.defaultTo` attribute in the Content-Type Builder write API by setting it as a tuple `[value, { isRaw: true }]`. Depending on the database engine, this enabled arbitrary file read, denial of service, or remote code execution against the database server.
- CVE-2025-64526Medium
In Strapi versions prior to 5.45.0, the rate-limit middleware in the users-permissions plugin derived its rate-limit key in part from `ctx.request.body.email`, including on routes whose body schema does not contain an email field (e.g. /auth/local, /auth/reset-password, /auth/change-password). An unauthenticated attacker could include an arbitrary email value in the request body to obtain a fresh rate-limit key per request, effectively bypassing per-IP throttling and enabling high-volume credential brute-force, password-reset code brute-force, and credential-stuffing attempts.
- CVE-2025-53092Medium
Strapi versions prior to 5.20.0 contain a CORS misconfiguration vulnerability in default installations. By default, Strapi reflects the Origin header value in the Access-Control-Allow-Origin response header without proper validation or whitelisting, allowing an attacker-controlled site to send credentialed requests to the Strapi backend. The vulnerability is fixed in version 5.20.0.
Original NVD description (English source)
Strapi is an open-source headless content management system. Prior to version 4.10.8, anyone (Strapi developers, users, plugins) can make every attribute of a Content-Type public without knowing it. The vulnerability only affects the handling of content types by Strapi, not the actual content types themselves. Users can use plugins or modify their own content types without realizing that the `privateAttributes` getter is being removed, which can result in any attribute becoming public. This can lead to sensitive information being exposed or the entire system being taken control of by an attacker(having access to password hashes). Anyone can be impacted, depending on how people are using/extending content-types. If the users are mutating the content-type, they will not be affected. Version 4.10.8 contains a patch for this issue.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

