CVE-2026-27886
HighSummary
Strapi is an open-source content management system that in versions from 4.0.0 to prior to 5.37.0 did not sufficiently sanitize query parameters when filtering content via relational fields. An unauthenticated attacker could use the `where` query parameter to perform a boolean-oracle attack against private fields in the `admin_users` table, allowing for administrative account takeover.
Risk Assessment
The risk to the organization is the potential for an attacker to take over an administrator account without authentication, which could lead to unauthorized access to sensitive data and system functions.
Recommendation
It is recommended to update Strapi to version 5.37.0 or later to patch this vulnerability and to review and strengthen query parameter sanitization in the application.
Other vulnerabilities in Strapi
See all- CVE-2023-22894MediumActively exploited
Strapi through 4.5.5 allows attackers with admin panel access to discover sensitive user details by exploiting the query filter. Attackers can filter users by columns containing sensitive information and infer values from API responses. Super admin can discover password hashes and password reset tokens of all users.
- CVE-2026-108114Medium
Strapi versions 5.47.0 through 5.57.0 contain an improper authorization vulnerability that allows admin API tokens to retain all-field Content Manager access after the owner's role is field-restricted. Because reconcileTokenPermissionsToUserCeiling ignores token permissions with omitted or null fields, token holders can keep reading content fields an administrator removed from the role.
- CVE-2026-90561High
Strapi versions 4.x through 4.26.2 and 5.x before 5.48.1 contain a stored cross-site scripting vulnerability in the content manager WYSIWYG preview component that fails to strip script tags from rich text. An Author-role user can store malicious script tags in rich text fields that execute in an Editor or Super Admin's session when the preview pane is expanded, enabling account takeover.
- CVE-2026-57997Medium
The Strapi users-permissions plugin fails to restrict JWT algorithms when plugin::users-permissions.jwt.algorithm is not explicitly configured, allowing acceptance of HS384 and HS512 tokens alongside HS256. Attackers possessing the jwtSecret can mint tokens with non-standard HMAC variants to bypass algorithm restrictions and weaken authentication controls.
- CVE-2026-22707Medium
In Strapi versions prior to 5.33.3, the Upload plugin's Content API endpoints did not enforce administrator-configured MIME type restrictions. An authenticated user with Content API upload permission could upload disallowed file types, including HTML and SVG, potentially leading to admin session hijack in default deployments.
- CVE-2026-22706Medium
In Strapi prior to 5.33.3, changing or resetting a user's password did not invalidate existing refresh-token sessions by default, because the invalidation step depended on a caller-supplied deviceId. An attacker with a previously obtained refresh token could continue minting new access tokens after the legitimate user reset their password, maintaining unauthorized access for up to 30 days. The patch in 5.33.3 invalidates all refresh tokens on every password change and reset.
- CVE-2026-22599High
In Strapi (4.x before 4.26.1 and 5.x before 5.33.2), an authenticated administrator could inject arbitrary SQL statements through the `column.defaultTo` attribute in the Content-Type Builder write API by setting it as a tuple `[value, { isRaw: true }]`. Depending on the database engine, this enabled arbitrary file read, denial of service, or remote code execution against the database server.
- CVE-2025-64526Medium
In Strapi versions prior to 5.45.0, the rate-limit middleware in the users-permissions plugin derived its rate-limit key in part from `ctx.request.body.email`, including on routes whose body schema does not contain an email field (e.g. /auth/local, /auth/reset-password, /auth/change-password). An unauthenticated attacker could include an arbitrary email value in the request body to obtain a fresh rate-limit key per request, effectively bypassing per-IP throttling and enabling high-volume credential brute-force, password-reset code brute-force, and credential-stuffing attempts.
- CVE-2025-53092Medium
Strapi versions prior to 5.20.0 contain a CORS misconfiguration vulnerability in default installations. By default, Strapi reflects the Origin header value in the Access-Control-Allow-Origin response header without proper validation or whitelisting, allowing an attacker-controlled site to send credentialed requests to the Strapi backend. The vulnerability is fixed in version 5.20.0.
- CVE-2025-3930Medium
Strapi uses JSON Web Tokens (JWT) for authentication. After logout or account deactivation, the JWT is not invalidated, allowing an attacker who has stolen or intercepted the token to reuse it until its expiration date (default 30 days). The existence of the /admin/renew-token endpoint allows indefinite renewal of near-expiration tokens, further increasing the impact. This issue is fixed in version 5.24.1.
Original NVD description (English source)
Strapi is an open source headless content management system. Strapi versions starting in 4.0.0 and prior to 5.37.0 did not sufficiently sanitize query parameters when filtering content via relational fields. An unauthenticated attacker could use the `where` query parameter on any publicly-accessible content-type with an `updatedBy` (or other admin-relation) field to perform a boolean-oracle attack against private fields on the joined `admin_users` table, including the `resetPasswordToken` field. Extracting an admin reset token via this oracle made full administrative account takeover possible without authentication. When a filter such as `where[updatedBy][resetPasswordToken][$startsWith]=a` was applied to a public Content API endpoint, the underlying query generation performed a `LEFT JOIN` against the `admin_users` table and emitted a `WHERE` clause referencing the joined column. The query parameter sanitization layer did not block operator chains that traversed into relational target
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

