Katalog podatności CVE

Przetłumaczone opisy podatności z bazy NVD NIST - w języku polskim

Przeglądaj podatności według pakietu

Katalog CISA KEV zaktualizowany: (v2026.11.06)

Cotygodniowy digest CVE

Jeden mail w tygodniu z nowo opublikowanymi podatnościami, o których warto wiedzieć. Bez zakładania konta.

Digest dotyczy ogólnie nowych podatności, nie Twoich serwerów. Jeśli chcesz wiedzieć, które z nich faktycznie działają w Twojej infrastrukturze, tym zajmuje się Secvalis : skanuje Twoje maszyny i zgłasza wyłącznie to, co ich dotyczy.

Zgadzam się na otrzymywanie cotygodniowego digestu CVE na podany adres e-mail. Zgodę mogę wycofać w każdej chwili linkiem w stopce każdej wiadomości.

CVE-2023-50868
Wysokie
—

Podatność w protokole DNS, związana z aspektem Closest Encloser Proof w RFC 5155 (gdy pominięto wytyczne RFC 9276), umożliwia zdalnym atakującym przeprowadzenie ataku typu „odmowa usługi” (DoS) poprzez wywołanie nadmiernego zużycia CPU na obliczenia SHA-1. Atak polega na wysyłaniu odpowiedzi DNSSEC w ramach ataku na losowe subdomeny, znanego jako problem NSEC3.

CVE-2019-16228
Wysokie
—

W bibliotece py-lmdb 0.97 odkryto błąd dzielenia przez zero w funkcji mdb_env_open2, który występuje, gdy funkcja mdb_env_read_header odczyta zerową wartość dla określonego pola rozmiaru. Problem może zostać wykorzystany poprzez dostarczenie spreparowanego pliku data.mdb.

CVE-2022-42919
Wysokie
—

Podatność w Pythonie 3.9.x przed 3.9.16 i 3.10.x przed 3.10.9 na systemie Linux umożliwia lokalną eskalację uprawnień w niestandardowej konfiguracji. Biblioteka multiprocessing z metodą startową forkserver pozwala na deserializację pickle'ów od dowolnego użytkownika w tej samej sieci lokalnej maszyny.

CVE-2023-27043
Średnie
—

Moduł email w Pythonie do wersji 3.11.3 błędnie parsuje adresy e-mail zawierające znaki specjalne. Nieprawidłowa część nagłówka RFC2822 jest identyfikowana jako wartość addr-spec.

CVE-2020-36242
Krytyczne
—

W pakiecie cryptography dla języka Python przed wersją 3.3.2, sekwencje wywołań funkcji aktualizującej szyfrowanie symetryczne dla danych o rozmiarze wielu gigabajtów mogą prowadzić do przepełnienia liczb całkowitych i przepełnienia bufora, co zostało zademonstrowane na klasie Fernet.

CVE-2026-33179
Średnie
—

Podatność w bibliotece libfuse w wersjach od 3.18.0 do 3.18.1 powoduje wyłuskanie wskaźnika NULL i wyciek pamięci w funkcji fuse_uring_init_queue. Lokalny użytkownik może wykorzystać ten błąd do awarii demona FUSE lub wyczerpania zasobów systemowych.

CVE-2022-4415
Średnie
—

Podatność w systemd powoduje, że systemd-coredump nie respektuje ustawienia jądra fs.suid_dumpable, co może prowadzić do lokalnego wycieku informacji.

CVE-2023-31484
Wysokie
—

Podatność w CPAN.pm przed wersją 2.35 powoduje, że nie weryfikuje on certyfikatów TLS podczas pobierania dystrybucji przez HTTPS. Oznacza to, że atakujący typu man-in-the-middle może podmienić pobierane pakiety na złośliwe.

CVE-2019-20916
Wysokie
—

Podatność w pakiecie pip dla języka Python przed wersją 19.2 umożliwia przemieszczanie się po katalogach (directory traversal) podczas instalacji z podanego URL. Atakujący może wykorzystać nagłówek Content-Disposition zawierający '../' w nazwie pliku, co pozwala na nadpisanie plików, np. /root/.ssh/authorized_keys.

CVE-2023-4641
Średnie
—

W narzędziu shadow-utils wykryto usterkę polegającą na nieprawidłowym czyszczeniu bufora przy dwukrotnym wprowadzaniu nowego hasła. Jeśli drugie wprowadzenie hasła zakończy się niepowodzeniem, pierwsze hasło pozostaje w pamięci, co może umożliwić atakującemu z odpowiednim dostępem jego odzyskanie.

CVE-2024-13454
Nieznane
—

Słaby algorytm szyfrowania w Easy-RSA w wersjach od 3.0.5 do 3.1.7 umożliwia lokalnemu atakującemu łatwiejsze złamanie prywatnego klucza CA, gdy został on utworzony przy użyciu OpenSSL 3.

GHSA-3x7f-q7wf-fp73
Nieznane
—

W bibliotekach Net::SSH::Proxy::Command oraz Net::SSH::Proxy::Jump możliwa jest iniekcja poleceń powłoki. Gdy aplikacja konfiguruje proxy i przekazuje do Net::SSH.start (lub ciąg jump do Proxy::Jump.new) wartości host, port lub remote_user pod wpływem atakującego, metaznaki powłoki w tych wartościach mogą zostać zinterpretowane.

GHSA-ggxh-cfwq-5xqc
Nieznane
—

Metoda Net::SSH::Transport::Session#poll_message umieszcza każdy pakiet odebrany podczas wymiany kluczy, który nie znajduje się na liście dozwolonych podczas KEX, w nieograniczonej kolejce @queue (tablica) bez limitu rozmiaru. Złośliwy serwer, który ukończy KEXINIT (wprowadzając net-ssh w stan oczekiwania na KEX), a następnie zalewa nie dozwolonymi pakietami, może powodować nieograniczony wzrost pamięci.

CVE-2025-0495
Średnie
—

Buildx to wtyczka CLI Docker, która rozszerza możliwości budowania za pomocą BuildKit. Backendy pamięci podręcznej obsługują poświadczenia, ustawiając sekrety bezpośrednio jako wartości atrybutów w konfiguracji cache-to/cache-from. Gdy są one dostarczane jako dane wejściowe użytkownika, te bezpieczne wartości mogą zostać przypadkowo przechwycone w śladach OpenTelemetry.

CVE-2024-9681
Średnie
—

Gdy curl ma używać HSTS, czas wygaśnięcia dla subdomeny może nadpisać wpis w pamięci podręcznej domeny nadrzędnej, powodując wcześniejsze lub późniejsze wygaśnięcie niż zamierzono. Dotyczy to aplikacji używających HSTS i adresów URL z niebezpiecznym schematem HTTP://.

CVE-2019-20633
Niskie
—

W GNU patch do wersji 2.7.6 występuje podwójne zwolnienie pamięci w funkcji another_hunk w pliku pch.c, co może prowadzić do odmowy usługi poprzez spreparowany plik łatki. Problem wynika z niekompletnej poprawki dla CVE-2018-6952.

CVE-2024-51744
Niskie
—

Niejasna dokumentacja zachowania błędów w funkcji `ParseWithClaims` w golang-jwt może prowadzić do sytuacji, w której użytkownicy nie sprawdzają błędów w odpowiedni sposób. Szczególnie, jeśli token jest zarówno wygasły, jak i nieprawidłowy, zwracane błędy mogą być mylące.

CVE-2025-5399
Średnie
—

Z powodu błędu w kodzie WebSocket w libcurl, złośliwy serwer może wysłać specjalnie spreparowany pakiet, który powoduje, że libcurl wpada w nieskończoną pętlę busy-loop. Aplikacja nie może uciec z tej pętli inaczej niż przez zabicie wątku/procesu. Może to być użyte do DoS.

CVE-2024-6197
Wysokie
—

Parser ASN1 w libcurl zawiera funkcję utf8asn1str() używaną do parsowania łańcucha UTF-8 ASN.1. Może on wykryć nieprawidłowe pole i zwrócić błąd. Niestety, podczas tego procesu wywołuje również free() na 4-bajtowym buforze lokalnym na stosie. Większość nowoczesnych implementacji malloc wykrywa ten błąd i natychmiast przerywa działanie.

CVE-2024-45310
Średnie
—

runc 1.1.13 i wcześniejsze oraz 1.2.0-rc2 i wcześniejsze mogą zostać oszukane do tworzenia pustych plików lub katalogów w dowolnych lokalizacjach w systemie plików hosta poprzez współdzielenie woluminu między dwoma kontenerami i wykorzystanie określonych operacji.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS